PDA

Visualizza la versione completa : Server dedicato Qmail e Co.


Sclerato
13-07-2007, 14:56
Salve,

da alcuni giorni sto sbattendo la testa per far funzionare le email su un server dedicato Linux, dove c'e' installato Plesk come frontend, e Qmail per la posta.
La solita funzione Php mail() non fa uscire le email.
Premetto che queste problematiche le ho incontrate da 2-3 giorni e sono quasi totalmente ignorante in materia.
Cosi' leggendo qua e la per il web, sono arrivato alla conclusione che qmail non e' settato come dovrebbe, in particolare sto seguendo le indicazioni in questo post:
http://forum.html.it/forum/showthread.php?threadid=1058090&perpage=15&highlight=plesk&pagenumber=1

Accedendo con SSH al server, e tentando di mandare una email (su server di email.it in questo caso), mi viene risposto un "illegal impersonation" che, se ho capito almeno qualcosina sul funzionamento dei server di posta, sta a significare server SMTP di destinazione non sa chi e' il mio server da cui invio, e gli risponde "che vuoi? non ti conosco...".



$ telnet 80.247.70.43 25
Trying 80.247.70.43...
Connected to mx.email.it (80.247.70.43).
Escape character is '^]'.
220 smtp-in03.email.it ESMTP
HELO localhost.localdomain
250 smtp-in03.email.it
MAIL FROM:<nobody@nowhere.com>
250 2.1.0 Ok
RCPT TO:<nobody@nowhereelse.com>
554 5.7.1 <localhost.localdomain>: Helo command rejected: Illegal impersonation in HELO
quit
221 2.0.0 Bye
Connection closed by foreign host.


Sempre dal post di cui sopra, sono spero correttamente arrivato alla conclusione che ci sono mancanze nei file hosts e hostname di qmail.



$ cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
$ cat /etc/hostname
cat: /etc/hostname: No such file or directory


eseguendo un telnet sul mio server, il servizio SMTP sembra sia attivo



$ telnet 62.149.202.95 25
Trying 62.149.202.95...
Connected to host95-202-149-62.serverdedicati.aruba.it (62.149.202.95).
Escape character is '^]'.
220 mail.tecnobit.it ESMTP
HELO mail.tecnobit.it
250 mail.tecnobit.it
MAIL FROM:<nobody@nowhere.com>
250 ok
RCPT TO:<nobody@nowhereelse.com>
553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)


Su Plesk come nome host completo (fqdn (?)) e' impostato localhost.localdomain
Tentavo anche di vedere il maillog, ma mi restituisce questo errore:



$ cat /var/log/maillog
cat: /var/log/maillog: Permission denied


Se qualcuno mi puo' aiutare a districarmi in questa cosa lo ringrazio fin da subito.
(Caleb ti un colpo ! :D )

Sclerato
13-07-2007, 17:51
Allora, sto facendo dei progressi... :dh˛:
Dopo aver cambiato di file hosts cosi:


127.0.0.1 localhost.localdomain localhost
mioIP mail.tecnobit.it mail


E con due DNS cosi' impostati
A mail.tecnobit.it mioIP
MX(10) tecnobit.it

Se riprovo a inviare una mail passando dal server SMTP di email.it



[root@mail ~]# telnet 80.247.70.43 25
Trying 80.247.70.43...
Connected to mx.email.it (80.247.70.43).
Escape character is '^]'.
220 smtp-in03.email.it ESMTP
helo mail.tecnobit.it
250 smtp-in03.email.it
mail from:<test@email.it>
250 2.1.0 Ok
rcpt to:<stefano.mocellin@email.it>
250 2.1.5 Ok
data
354 End data with <CR><LF>.<CR><LF>
bla bla bla
.
250 2.0.0 Ok: queued as 9F6B34401A
quit
221 2.0.0 Bye
Connection closed by foreign host.


Ora mi riconosce come server e mi fa passare, ovviamente non funziona come relayer aperto ma posso spedire solo a caselle di posta email.it
Fin qui tutto ok.

Ora, se provo a mandare una mail dal mio server SMTP, al momento non e' impostato come relayer aperto, e se provo ad esempio a mandare una mail sul mio indirizzo di email.it



[root@mail ~]# telnet 62.149.202.95 25
Trying 62.149.202.95...
Connected to mail.tecnobit.it (62.149.202.95).
Escape character is '^]'.
220 mail.tecnobit.it ESMTP
helo mail.tecnobit.it
250 mail.tecnobit.it
mail from:<test@test.it>
250 ok
rcpt to:<miamail@email.it>
553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)
quit
221 mail.tecnobit.it
Connection closed by foreign host.


Mi dice ovviamente che non e' autorizzato a farlo, in quanto email.it non e' incluso nel file rcpthosts (se lo aggiungo infatti invia).

Il problema e' che dal sito sul mio dominio, io ho la necessita' di inviare email ad utenti che hanno caselle di posta sui piu' disparati ISP, ma cosi' com'e' configurato qmail immagino non me lo lascerebbe fare.

Come posso fare?
Spero che qualcuno mi dia qualche dritta.
Grazie

Loading