PDA

Visualizza la versione completa : Problemi ad accedere a ntfs


MatCap83
13-07-2007, 19:25
Dal centro di controllo di mandriva ho installato i driver ntfs-3g, con tutti i pacchetti necessari, ma non riesco in nessun modo ad accedere in scrittura alle partizioni con NTFS :dh: :dh: !!! Ho provato e riprovato, ma nulla :dh:

GunMan
13-07-2007, 20:48
una volta installato il modulo fuse con i relativi driver, necessario specificare di voler usare tali driver in sede di mount della partizione.

puoi anche modificare ad uopo fstab in modo che essa venga montata all'avvio seguendo tali direttive.

:ciauz:

mykol
13-07-2007, 20:59
guarda in /etc/fstab se ti ha aggiunto la riga relativa a ntfs-3g. Nom ricordo la sintassi corretta, ma se fai una ricerca sul forum, se ne discusso.

MatCap83
14-07-2007, 11:22
Ok, sono riuscito a farlo funzionare il modulo, ho modificato tutto e ora in scrittura funziona!! :yuppi: Per quando sono andato a rimontare le partizione ntfs mi apparsa 'sta scritta:

"WARNING: Deficient Linux kernel detected. Some driver features are
not available (swap file on NTFS, boot from NTFS by LILO), and
unmount is not safe unless it's made sure the ntfs-3g process
naturally terminates after calling 'umount'. If you wish this
message to disappear then you should upgrade to at least kernel
version 2.6.20, or request help from your distribution to fix
the kernel problem. The below web page has more information:
http://ntfs-3g.org/support.html#fuse26 "

Devo preoccuparmi se lascio la versione che ho ora del kernel :confused: ?? Per la precisione la 2.6.17...

GunMan
14-07-2007, 12:59
non dovresti avere problemi teoricamente solo un warning che ti informa che con la versione del kernel che hai installato alcune features non sono disponibili.

:ciauz:

MatCap83
14-07-2007, 15:18
Nuovo problema :cry: , la scrittura sulle partizioni ntfs non funziona quando avvio il sistema :dh: . Se smonto manualmente una partizione e poi la rimonto con questo comando:

mount -t ntfs-3g /dev/hda1 /mnt/partizione

tutto ok. Ma quando accedo il sistema dopo un riavvio non funziona, in particolare ho modificato il file fstab cos:

/dev/sda5 / ext3 noatime 1 1
/dev/sda7 /home ext3 noatime 1 2
/dev/hda /media/cdrom auto umask=0022,users,iocharset=utf8,noauto,ro,exec 0 0
/dev/sda1 /mnt/win_c ntfs-3g umask=0022,nls=utf8,ro 0 0
/dev/sdb1 /mnt/win_c2 ntfs-3g umask=0022,nls=utf8,ro 0 0
/dev/sda2 /mnt/win_d ntfs-3g umask=0022,nls=utf8,ro 0 0
none /proc proc defaults 0 0
none /tmp tmpfs defaults 0 0
/dev/sda6 swap swap defaults 0 0

in particolare ho aggiunto la voce ntfs-3g dopo le partizioni ntfs, per il caricamento del modulo all'avvio, ma non va :bh: . Che devo fare??

mykol
14-07-2007, 16:51
dove le hai prese quelle righe relative ad ntfs-3g che hai in /etc/fstab. Sicuro che siano corrette ? te le monta in sola lettura ? non te le monta proprio ?

prova magari a mettere

/dev/sda1 /mnt/win_c -t ntfs-3g umask=0022,nls=utf8,ro 0 0

hai caricato il modulo fuse ?

Prova fare qualche ricerca sui forum o su google.it/linux. Mi ricordo che poco tempo fa ho letto qualcosa in merito

MatCap83
14-07-2007, 18:04
Sono riuscito a risolvere, dopo 1000 tentativi :D , finalmente :yuppi: ... Ho cercato un po' su google, e ho capito che bisogna aggiungere ad esempio alla fine del file fstab la riga:

/dev/sda1 /mnt/partizione ntfs-3g default 0 0

in questo modo possibile scrivere fin dall'inizio. L'unica cosa che ho notato facendo in questo modo che durante il caricamento del sistema mi appare scritto che il file fstab non contiene la linea di chiusura, e come devo fare?

mykol
14-07-2007, 21:49
semplicissimo (almeno credo e spero !), riapri fstab con un editor da root e dai un <invio> alla fine dell'ultima riga, se no la riga non viene chiusa correttamente.

Scusa, ma questa riga

/dev/sda1 /mnt/win_c ntfs-3g umask=0022,nls=utf8,ro 0 0

te l'ha messa mandriva in automatico o l'hai trovata da qualche parte ?

Se non funziona cos prova a mettere la riga con l'ntfs dopo quelle degli altri dischi e non alla fine di fstab

GunMan
15-07-2007, 00:29
pi che altro mi pare che l'opzione ro (read only) non sia particolarmente indicata.

proverei con qualcosa di simile



/dev/sda1 /mnt/partizione ntfs-3g user,auto,silent,umask=0,locale=it_IT.utf8 0 0


:ciauz:

Loading