PDA

Visualizza la versione completa : [UBUNTU 7] <Problema avvio e scheda video> Configurazione xorg.conf e NVidia


tony83
16-07-2007, 01:21
Ciao a tutti,

ho avuto un problema con il file xorg.conf (X Server), e scheda video a tal punto che non si avviava + ubuntu..

ecco la discussione precedentemente aperta:



http://forum.html.it/forum/showthread.php?s=&threadid=1144218


premetto che una scheda: NV11DDR [GeForce2 MX 100 DDR/200 DDR]

Ora sono riuscito a capire di pi e avviare ubuntu, ho provato a reinstallare nvidia e tutto quanto, ma ho ancora dei problemi... ho deciso di aprire una nuova discussione visto che cmq il discorso cambiato,

Dopo vari tentativi ho deciso di reinstallare tutto quanto, seguendo questa guida:



http://ubuntubible.wordpress.com/2006/11/13/guida-1-attivazione-accelerazione-3d-per-nvidia/


premetto quindi che la reintallazione dei driver ho fatto:



sudo apt-get install nvidia-glx


Sembra funzionare regolarmente tutto per mi accorgo che:

facendo da terminale: glxinfo mi restituisce:



name of display: :0.0
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x21 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x22 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None


facendo Restricted Driver manager mi restituisce:

NVIDIA ACCELERATOR GRAPHICS DRIVER --> Enable ceccato, ma lo status "Not in use"

GL DESKTOP: Enable GL DESKTOP sempre disabilitato anche se lo abilito..

ed effetti grafici quando provo ad attivarlo ogni volta l0 devo attivare e quando vado per attivarlo mi dice: riavviare di nuovo gli effetti Desktop al prossimo riavvio, come se funzionasse, ma poi quando lo riavvio automaticamente mi ritrovo il file xorg.conf cambiato nella sezione device:
Driver "nvidia"
e non funziona.. poi lo cambio automaticamente nv e rifunziona... poi ricontrollo il tutto e rivedo che tutto come scritto sopra....

premetto che all'inizio mi ci aveva messo nvidia automaticamente lui, come doveva essere ma non sembra funzionare.. (non capisco poi perch in certi casi nv e in altri NVidia)

Questo il codice di xorg.conf che si trova in /etc/X11/xorg.conf




Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
Vendorname "Unknown"
Modelname "Unknown"
Horizsync 30.0 - 110.0
Vertrefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nv"
Vendorname "NVIDIA Corporation"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
Defaultdepth 24
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection


quindi con la seguente riga


Driver "nvidia"

invece che


Driver "nv"


mi restuisce questo e non si avvia:



ubuntu tenta di partire poi esce con una scermata blu con qualche scarabocchio e dice "impossibile avviare il server X, potrebbe non essere configurato correttamente", dopo aver cercato di installare e configurare i driver Nvidia..


Sinceramente xorg.conf quindi X Server ha chiaramente dei problemi con la scheda video ma non riesco a uscirne!.. :cry:

:dh: :dh: :dh:

DOVREI RIUSCIRE A INSTALLARE TUTTI GLI EFFETTI SPECIALI POSSIBILI, QUINDI GLI EFFETTI DESKTOP DI UBUNTU E SISTEMARE LA SCHEDA GRAFICA E IL FILE xorg.conf

Potete autarmi? :(

ps. compiz installato

GRAZIE ANTICIPATAMENTE

andy caps
16-07-2007, 02:13
secondome se vuoi usare i driver di ubuntu devi installare

linux-restricted-modules

poi dare un modprobe nvidia

per gli effetti, se la scheda regge, devi modificare

Section "Extensions"
Option "Composite" "Disable"
EndSection

con

Section "Extensions"
Option "Composite" "Enable"
EndSection


e piu in alto assicurarti di avere nella sezione modules

Section "Module"

Load "glx"

tony83
19-07-2007, 01:40
nulla... sembra essere tutto a posto.. :dh: :dh:

ho provato ad eseguire come qua ma niente:



http://pollycoke.wordpress.com/2006/10/10/usare-linstaller-per-i-driver-nvidia-su-ubuntu/


ho eseguito e verificato tutto, sembra giusto, tranne per modprobe che non so cosa sia.

posto ora lo stato attuale del mio xorg.conf



nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Wed Nov 1 19:47:17 PST 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "L1915S"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "nVidia Corporation NV11DDR [GeForce2 MX200]"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV11DDR [GeForce2 MX200]"
Monitor "L1915S"
DefaultDepth 24
Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


Ho installato questo: NVIDIA-Linux-x86-1.0-9629-pkg1.run

tony83
19-07-2007, 12:13
Su Section "Device" con nv invece che nvidia funziona come possibile?

andy caps
19-07-2007, 14:10
se non hai installato correttamente i driver chiaramente va con nv anche se non dovrebbe supportare accelerazione grafica

se i driver sono installati correttamente

sudo modprobe nvidia dovrebbe caricarlo

lsmod | grep nvidia dovrebbe mostrarlo

tony83
19-07-2007, 14:32
Originariamente inviato da andy caps
se non hai installato correttamente i driver chiaramente va con nv anche se non dovrebbe supportare accelerazione grafica

se i driver sono installati correttamente

sudo modprobe nvidia dovrebbe caricarlo

lsmod | grep nvidia dovrebbe mostrarlo

allora a casa prover a fare:

sudo modprobe nvidia

e

lsmod | grep nvidia

nel caso dovesse funzionare come devo procedere?

se invece non installato correttamnte chiaramete posso accedere con nv ma non risolvo perch non ho gi effetti desktop di ubuntu visto che richiedono la scheda grafica accelerata.. allora chiedevo come devo procedere anche in questo caso.. visto che ormai sto sull'orlo di mollare gli effetti grafici!!!! :dh: :dh:

andy caps
19-07-2007, 21:30
per gli effetti grafici devi avere i driver nvidia installati

se dopo avere dato sudo modprobe nvidia lo carica
al posto di nv devi mettere nvidia

poi installare compiz-fusion se hai messo i server di compiz-fusion

http://3v1n0.tuxfamily.org/blog/informatica/linux/ubuntu-compiz-git-repository/


poi devi aggiungere anche quelle parti che servono ad xorg.conf
se guardi il precedente tuo file di configurazione avevi

Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"

e sotto
Section "Extensions"
Option "Composite" "Enable"
EndSection


poi con il comando compiz --replace si avvia compiz

KaZaA
19-07-2007, 22:01
http://www.nvidia.com/object/IO_32667.html

Stando a quanto riportato dal sito dell'nvidia, la serie GeForce 2 MX dovrebbe essere supportata dalla versione dei driver 96xx, ma forse lo Xorg rileva male la scheda associandogli un'altro modello rispetto a quello del Product ID...forse la tua una scheda che non pi supportata dalla serie 96xx dei driver, come la GeForce 2 GTS o Pro...prova ad installare il pacchetto nvidia-glx-legacy

da Shell:

$ sudo apt-get install nvidia-glx-legacy

Per vedere se cos ti va...

tony83
20-07-2007, 01:14
niente ho provato tutto quello che mi avete detto.. ma non c' proprio verso.. Vorrei tanto capire dove sbaglio!!!!..... :dh: :dh: :dh: :dh: :dh: :dh: :dh: :dh: :dh: :dh: :dh: :dh:

tony83
20-07-2007, 11:09
Secondo questo manuale:

http://www.linuxtips.netsons.org/articles.php?lng=it&pg=95





Se all'avvio avete problemi e non parte pi l'interfaccia grafica, digitate:

$_ sudo dpkg-reconfigure xserver-xorg

Scegliete i driver "vesa" e andate avanti...
In seguito a questa procedura dovrebbe essere stato ripristinato il tutto, quindi rieseguite nuovamente la procedura.



Forse questo il problema?

poi da altre parti avevo letto che devo installare nvidia-glx-legacy invece che che nvidia-glx ... forse sono questi 2 i problemi...

che ne pensate?

Loading