PDA

Visualizza la versione completa : Scheda TV


noodles25
18-07-2007, 14:46
Salve ho una Pinnacle PCTV Hybrid Pro PCI e sembra essere stata riconosciuta correttamente da kUbuntu 7.04 (dopo aver caricato il modulo giusto). Tramite KdeTV faccio la scansione dei canali, ed effettivamente vengono trovati, ma poi non posso visualizzarli (schermata nera)

Sapete darmi una mano?

Grazie

mykol
18-07-2007, 15:55
sei sicuro che ti abbia riconosciuto la scheda ed il tuner corretti ?

In alcuni miei vecchi post sull'argomento ci sono link ad elenchi di schede coi rispettivi tuner.

La tua scheda usa il chip bt878 od il saa1....qualcosa ?

KaZaA
18-07-2007, 15:58
potrebbe essere un problema di Codec...lo stream video ricevuto da una scheda satellitare dovrebbe essere Mpeg2...guarda se hai il codec giusto...dovrebbe essere libmpeg2-4...cercalo con synaptic.

noodles25
18-07-2007, 16:15
si mykol i moduli sono quelli

kazaa dopo cerco se riesco a trovare dove impostargliela, poi vi dico


grazie per le risposte

mykol
18-07-2007, 16:25
quale, il bt878 od il saa... ?

noodles25
18-07-2007, 16:44
saa...qualcosa :D

eccoli, con un lsmod | grep saa

saa7134_dvb 20232 0
dvb_pll 15364 1 saa7134_dvb
video_buf_dvb 7684 1 saa7134_dvb
tda1004x 16644 2 saa7134_dvb
saa7134_alsa 15392 1
snd_pcm 79876 5 saa7134_alsa,snd_intel8x0,snd_ac97_codec,snd_pcm_o ss
saa7134 122080 2 saa7134_dvb,saa7134_alsa
video_buf 26116 4 saa7134_dvb,video_buf_dvb,saa7134_alsa,saa7134
compat_ioctl32 2304 1 saa7134
ir_kbd_i2c 9872 1 saa7134
ir_common 31236 2 saa7134,ir_kbd_i2c
videodev 28160 3 sn9c102,gspca,saa7134
v4l2_common 25216 4 sn9c102,tuner,saa7134,videodev
v4l1_compat 15236 2 saa7134,videodev
snd 54020 21 saa7134_alsa,snd_mpu401,snd_mpu401_uart,snd_intel8 x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pc m,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_se q_device
i2c_core 22784 8 saa7134_dvb,dvb_pll,tda1004x,i2c_ec,tuner,saa7134, ir_kbd_i2c,i2c_nforce2

mykol
18-07-2007, 19:28
con il saa71134 non sono molto pratico perché ho un bt878, ma sul forum in passato se ne č parlato anche del saa... e ci trovi anche dei link ad howto che ne trattano.

parecchie discussioni interessanti (http://www.google.it/linux?hl=it&q=saa7134&btnG=Cerca&meta=lr%3Dlang_it)

che distro usi ?

in una console di root prova a dare

lspci

e vedi se viene correttamente riconosciuta.

Cerca anche in qualche elenco che tuner monta la tua scheda (se puoi dai anche un'occhiata al tuner sulla scheda per vedere se c'č qualche sigla.

noodles25
19-07-2007, 10:52
perfetto, ho fatto veramente i danni :D

avevo letto che servivano i nuovi driver v4l e cosė li ho compilati da sorgente come c'era scritto su un gruppo di discussione (ho una kubuntu 7.04), poi ho riavviato per non far sovrapporre i moduli vecchi/nuovi. Cosė facendo non ho risolto assolutamente nulla :D anzi prima funzionava la webcam, ora non va pių :D infatti se faccio:


leonardo@PC-Desktop:~$ mplayer tv:// -tv driver=v4l:width=352:height=288
MPlayer 2:1.0~rc1-0ubuntu9.1 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) XP 2500+ (Family: 6, Model: 10, Stepping: 0)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection.
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing tv://.
TV file format detected.
Selected driver: v4l
name: Video 4 Linux input
author: Alex Beregszaszi
comment: under development
================================================== ===============
WARNING: YOU ARE USING V4L DEMUXER WITH V4L2 DRIVERS!!!
As the V4L1 compatibility layer is broken, this may not work.
If you encounter any problems, use driver=v4l2 instead.
Bugreports on driver=v4l with v4l2 drivers will be ignored.
================================================== ===============
ioctl get capabilites failed: Invalid argument


MPlayer interrupted by signal 11 in module: demux_open
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.


mi č sembrato di capire che uso il demuxer (famossissimo demuxer
:master: ) di v4l con il v4l2....

quindi ora non va nč la tv nč la webcam

Loading