PDA

Visualizza la versione completa : Problemi Con Il Proxy Di Linux


Mirco65
18-07-2007, 17:32
Salve !
Ho un proxy Linux e da un pò di tempo da dei problemi al momento del boot;
Dopo aver aspettato un bel pò di tempo parte e ho notato che il disco sta sempre in attività;
ho fatto un ps -efa per vedere i processi e ho notato che ci sono moltissimi processi con squidguard -c /etc/squid/sqidguard.conf

Quale è il problema e secondo voi cosa sta succedendo ?
Premesso che non sono un'esperto di Linux ma conosco Unix.

sacarde
18-07-2007, 19:53
ma ha iniziato a farlo adesso ?

vedi se accede in rete ?

prova a avviare solo squid senza squidguard

Mirco65
19-07-2007, 09:24
Ciao !

per la tua risposta !

In rete ci va ma a volte si "imballava"

per il momento abbiamo bloccato lo squidguard rinominando il file squid.conf sotto etc e in questo modo il disco non sta in più a lavorare di continuo e va bene.

Inoltre (cosa più grave), al boot, ci mette un bel pò di tempo per partire.

Altra cosa : come si fa a fare il kernel (non da grafica) ? C'è un comando veloce ?
Ho letto dxa qualche parte che si usa make dep, make clear ecc. ma quando eseguo make mi da comando sconosciuto !
da quale directory si fa ?
grazie

sacarde
19-07-2007, 10:21
i dns sono a posto ? giarda nel file /etc/resolv.conf

non ho capito ... vuoi ricompilare il kernel ?

per non far partire la grafica devi modificare il runlevel di default (guarda dentro /etc/inittab)


leggiti qualcosa a riguardo esempio su www.openskill.info

Mirco65
19-07-2007, 11:05
Quando abbiamo rinominato il file squidguard.conf sotto /etc/squid in modo tale da non stressare il disco e fatto ripartire, ci ha messo un bel pò di tempo per fare il boot ma poi una volta partito il PC, è tutto ok nel senso che il disco non era attivo di continuo !
(Fatto per fare una prova)

Abbiamo rimesso a posto il file squidguard.conf e fatto ripartire;
ci ha messo lo stesso molto tempo e comunque siamo al punto di partenza nel senso che il disco nonostante non riceva comandi e il PC non è in rete, continua a lavorare in modo continuativo come se stesse facendo qualcosa;
da un ps -efa |more risultano solo una serie di elenchi di processi legati a squidguard.conf.
Mi chiedo come mai tutta questa attività e quale potrebbe essere il problema che al boot ci mette almeno 20 minuti poer partire.
Grazie

Loading