PDA

Visualizza la versione completa : debian unstable errore nell'aggiornamento


jaso
27-07-2007, 21:46
Ciao a tutti,

appena tornato da una breve vacanza, accendo il pc e aggiorno la mia sid.
Come prevedevo ci sono stati tanti aggioramenti: non perdo tempo a leggerli tutti e dico di aggiornare.
non appena aggiornato non mi funziona pi kde.

evidentemente mi ha disinstallato parecchi pacchetti, se lancio:

apt-get install kdebase

mi dice:

Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso
Reading state information... Fatto
Alcuni pacchetti non possono essere installati. Questo pu voler
dire che stata richiesta una situazione impossibile oppure, se
si sta usando la distribuzione "unstable", che alcuni pacchetti
richiesti non sono ancora stati creati o rimossi da incoming.

Poich stata richiesta solo una singola operazione molto facile che
il pacchetto semplicemente non sia installabile, si consiglia
di inviare un "bug report" per tale pacchetto.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
kdebase: Dipende: kdebase-kio-plugins (>= 4:3.5.7-2) ma non sta per essere installato
Dipende: konqueror (>= 4:3.5.7-2) ma non sta per essere installato
E: Pacchetto non integro
localhost:/home/alex#

e poi se lancio :
apt-get install synaptic
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso
Reading state information... Fatto
Alcuni pacchetti non possono essere installati. Questo pu voler
dire che stata richiesta una situazione impossibile oppure, se
si sta usando la distribuzione "unstable", che alcuni pacchetti
richiesti non sono ancora stati creati o rimossi da incoming.

Poich stata richiesta solo una singola operazione molto facile che
il pacchetto semplicemente non sia installabile, si consiglia
di inviare un "bug report" per tale pacchetto.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
synaptic: Dipende: libapt-inst-libc6.5-6-1.1 ma non installabile
Dipende: libapt-pkg-libc6.5-6-4.4 ma non installabile
E: Pacchetto non integro
localhost:/home/alex#

come faccio a risolvere?

andy caps
27-07-2007, 23:39
:master: si un capolavoro estivo dei mantainer

probabilmente qualcuno in ferie

aggiornando openexr rimuove kdebase e molti files di kde e anche a synaptic manca qualche versione aggiornata libreria di libapt

synaptic probabilmente risolvono con l'aggiornamento di domani ( in incoming ci sono gia i pacchetti aggiornati
kdebase non so

:bh:

jaso
27-07-2007, 23:51
mmm
ok allora sembra che l'unica soluzione aspettare. cmq ho risolto temporaneamente installando con apt-get -f install alcuni pacchetti essenziali per kde..

francofait
28-07-2007, 02:45
Dist-upgrade eseguito ora , 274 pacchetti aggiornati 27 installati 0 eliminati nessun errore.

# deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 xfce-CD Binary-1 20070407-12:12]/ etch contrib main

# deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 xfce-CD Binary-1 20070407-12:12]/ etch contrib main

deb http://ftp.unina.it/pub/linux/distributions/debian/ etch main contrib non-free
deb http://ftp.unina.it/pub/linux/distributions/debian/ lenny main contrib non-free

deb http://security.debian.org/ etch/updates main contrib

deb http://ftp.unina.it/pub/linux/distributions/debian/ sid main contrib non-free
deb http://ftp.unina.it/pub/linux/distributions/debian/ experimental main contrib non-free

deb http://www.debian-multimedia.org/ stable main
deb http://www.debian-multimedia.org/ testing main
deb http://www.debian-multimedia.org/ sid main
deb http://www.orsobruno.net/debs/ experimental main
# unofficial http://www.debian-unofficial.org
deb http://ftp.debian-unofficial.org/debian/ sid main contrib non-free restricted
deb http://edevelop.org/debian/ unstable main

il mi sorcio attuale.

Loading