PDA

Visualizza la versione completa : Internet impossibile con Fedora 7


zobecl
28-07-2007, 13:04
Grazie in anticipo a chi mi aiuterà a risolvere...

Il problema è: sul mio PC ho installato Fedora 7 (64 bit). Tutto si avvia, tranne la connessione ad Internet. Quello che mi sconcerta è che inserendo nel browser l'IP del router questo mi risponde correttamente con la maschera si login (in HTML), se inserisco un normale indirizzo web, tipo google.it si blocca e attende, dando poi sapere che il server è irraggiungibile. Quindi sullo stesso cavo LAN le informazioni transitano dal router al PC senza problemi, da internet al PC (o viceversa) CON problemi.

Seguendo poi attentamente la schermata precedente al login di Fedora (dove viene mostrato lo stato di avvio dei componenti, durante l'avvio del PC), noto che la "determinazione dell'indirizzo IP per Eth0", il dominio NIS e il "Router Discovering" falliscono.

Ho provato tutte le combinazioni (ehm... su base random, perché non ne capisco ancora granché) in Sistema / Rete, ma nulla da fare. Anche lì quando vado sul pulsante verde di avvio interfaccia, mi salta fuori l'errore inerente l'IP. Andando poi alla pagina del router, tutto sembra funzionare e siamo al primo paragrafo.

cacao74
28-07-2007, 13:28
Devi solamente impostare gli indirizzi dei server DNS...
e se non l'hai gia' fatto, definire come gateway il tuo router.
ciao

zobecl
28-07-2007, 18:41
Appena possibile provo.


Ciao
Grazie

zobecl
29-07-2007, 10:59
Ho provato a mettere l'IP del router come DNS server, ma il problema persiste. Potrebbe dipendere dal fatto che abbia 2 schede Ethernet sulla MB ? (Se si, sappiate che le ho provato a disabilitare da BIOS una per volta, ma non ho risolto)

andy caps
29-07-2007, 11:10
scrivi con un editor di testo i dns nel file /etc/resolv.conf

esempio

nameserver 212.216.112.112




da terminale puoi metterli con

echo "212.216.112.112" >> /etc/resolv.conf

prima di avviare il browser

altrimenti prova ad impostare manualmente anche il gateway

route add default gw ip-del-router

zobecl
29-07-2007, 23:04
Funziona.

Ci ho messo del tempo a capire che il 212.216.112.112 NON andava sostituito col mio router...

Comunque, per curiosità, il 212.216.112.112 cos'è ?

--
La navigazione mi sembra un pelino più lenta che su windows, non la parte di apertura pagina, ma di "attesa risposta server". è possibile questo scenario?

mykol
30-07-2007, 02:03
è l'IP di un server DNS di alice.

Per navigare più veloce metterei l'ip statico sul PC e disattiverei il DHCP sul router (se è attivato)

Per caso hai mica attivo l'IPV6 ? A me, con la mandriva rallentava moltissimo la navigazione.

Loading