PDA

Visualizza la versione completa : chiave usb in redhat enterprise 4


00FUMI
29-07-2007, 18:40
Ciao a tutti, premetto di essere un neofita all interno di s.o. linux, ho installato la distro red hat enterprise 4 e nn ho avuto alcun problema solo che al momento di montare una qualsiasi chiave usb tra i vari dispositivi presenti in /dev non vi e sda sda1 etc etc ....credo necessari per il completamento dell operazione.
Come posso risolvere il problema ....Grazie a chiunque rispondera!

mykol
29-07-2007, 18:51
ma in /etc/fstab non Ŕ elencata /sdev/sda o sda1, ecc... ?

00FUMI
30-07-2007, 00:04
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/hda5 swap swap defaults 0 0
/dev/hdc /media/cdrecorder auto pamconsole,fscontext=system_u:object_r:removable_t ,exec,noauto,managed 0 0


Questo e il risultato di fstab dopo aver inserito la chiave usb...io sinceramente non vedo nulla che possa aiutarmi a capire quale possa essere la chiave....

Grazie anticipatamente per le possibili risposte

mykol
30-07-2007, 01:53
hai ragione, anche nella mandriva 2007 spring, in /etc/fstab non c'Ŕ traccia della penna usb.

Ma quando la monto, cliccando sull'icona, in /etc/mtab compare la seguente riga

/dev/sda1 /media/disk vfat rw,nosuid,nodev,noatime,uhelper=hal,flush,uid=500, utf8,shortname=lower 0 0

In un'altra installazione sempre di mandriva (una vecchia mandriva, via via aggiornata a mandriva 2007) in /etc/fstab ho la seguente riga

/dev/sda1 /mnt/removable3 vfat pamconsole,exec,noauto,noatime,codepage=850,iochar set=iso8859-15,managed 0 0

(tutto su una riga sola)

e funziona altrettanto bene.

Ma quando la inserisci, non la "sente", non si aprono finestre.

A me nella mandriva spring la mette in una icona sul desktop (un monitor col computer vicino) in cui vengono visualizzate tutti i dischi con le loro partizioni, di nome periferiche.

00FUMI
30-07-2007, 09:57
no purtroppo non vedo traccia di lei ne su fstab ne su mtab ne su desktop ....non so proprio dove guardare diversamente.

peccato x questo problema ... prima usavo la redhat 9 ma avevo dei problemi sull installazione dei driver per la scheda video ...e allora sono passato alla enterprise 4 ma mi sa che ho risolto il probl dei driver video e accellerazione 3D e ho perso la possibilita d uso dei dispositivi usb!!!...mannaggia!!

Cmq grazie lo stesso per le risposte date!!

mykol
30-07-2007, 16:34
non Ŕ possibile che su una distro moderna non si possa usare l'USB ! Non hai il manuale, assistenza un forum ? Essendo una "enterprise" ....

La gestirÓ in modo insolito ... oppure bisogna vedere se carica i moduli necessari ...

Se la inserisci a PC acceso non succede nulla ? Non compaiono icone ? Hai mica ricompilato il kernel ?

Prova ancora dare in una console di root

lsusb

prima e dopo aver inserito la chiavetta e posta l'output

Prova anche a dare, sempre nella console di root (pima e dopo inserito la chiavetta)

lsmod |grep usb

In un modo o nell'altro deve funzionare.

Infine sempre nella solita console

df -H

e fdisk -l

da qualche parte deve saltare fuori

00FUMI
30-07-2007, 23:08
allora ho provato a dare il comando df -H e il risultato del comando e questo:

Filesystem Dimens. Usati Disp. Uso% Montato su
/dev/hda6 9,5G 4,7G 4,3G 53% /
none 264M 0 264M 0% /dev/shm----> non so cosa sia la chiave che cerco di montare ha dimensione 1GB

Spero di averti dato qualche spunto ah gli altri comando nn mi vengono riconosciuti da shell.

kruskaiev
31-07-2007, 00:12
Dai da root tail -f /var/log/messages e dopo attacca il Pendrive.. che righe ti vengono fuori?
Se non viene fuori niente allora ristacca il Pendrive e prova a dare:
- modprobe ohci_hcd
- modprobe uhci_hcd
- modprobe uhci_hcd

Dopo aver caricato i moduli riprova a dare tail -f /var/log/messages e attacca il Pendrive per vedere cosa ti da in output.

kruskaiev
31-07-2007, 00:14
Originariamente inviato da 00FUMI
Spero di averti dato qualche spunto ah gli altri comando nn mi vengono riconosciuti da shell.
Ma.. stai dando i comandi da root o da utente?

mykol
31-07-2007, 01:19
non Ŕ possibile che fdisk -l non funzioni. Lo devi dare da console di root come anche gli altri.

fdisk -l ti vede tutti i dischi anche se non montati.

Se non ti compare qualcosa tipo /dev/sda1 carica i moduli con i comandi che ti ha suggerito kruskaiev (modprobe ......) dati nella solita console di root e poi riprova fdisk -l

Loading