PDA

Visualizza la versione completa : problema grub (ubuntu) + winzoz


paolone919191
13-08-2007, 01:50
(postato anche sul forum di ubuntu)

Salve.
Attualmente possiedo 2 pc che mi hanno dato problemi simili con l'installazione di ubuntu per quanto riguarda il boot di windows:


CASO 1:

nel pc 1 ho 2 hd:

hda, suddiviso in:
hda1 (ntfs 103gb con windows)
hda2 (ntfs 50 gb con windows)

hdb, suddiviso in
hdb1 (ext3 36 gb con linux (/))>>>(ubuntu 7.0.4 I386)
hdb2 (swap 2 gb)

linux non mi da problemi di funzionamento, ma windows non mi parte; il punto che ho provato ad inserire il disco di xp ed entrare nella console (comando R) per fare un fixmbr, ma, secondo il cd, sul computer non c' alcuna versione di windows. Cosa devo fare?

NB: Linux legge tranquillamente tutti i dati delle 2 partizioni ntfs



CASO 2:

sull'unico hd ho le partizioni:

hda1 (ntfs con windows, 74 gb)
hda2 (ext3 con ubuntu (/), 70 gb)>>>>(ubuntu 7.0.4 AMD64)
hda3 (swap)

premettendo che su questo disco avevo installato acronis os selector, il problema questo:


dopo aver installato ubuntu con grub in hd0 linux mi parte senza problemi; windows invece no.
a questo punto ho provato a ripristinare il bootloader con acronis disk os selector (grazie ad una chiavetta usb che avevo creato per sicurezza), e quindi il bootloader mi si ripristinato, ma quando tento di far partire windows, il quale appare correttamente nella lista dei sistemi presenti sul pc, questo mi rimanda ad una schermata nera con un trattino lampeggiante e da li non si smuove.
Il cd di xp mi riconosce la partizione e riconosce anche la presenza di windows all'interno di esso. Ho provato quindi a fare il fixmbr ed il fixboot, ma quando riavvio mi appare sullo schermo MBR error...
cosa devo fare?

NB. Anche in questo caso linux legge la partizione di win






grazie x l'aiuto!!! :dh: :dh: :dh: :dh: :dh:

francofait
13-08-2007, 02:40
Originariamente inviato da paolone919191
(postato anche sul forum di ubuntu)

Salve.
Attualmente possiedo 2 pc che mi hanno dato problemi simili con l'installazione di ubuntu per quanto riguarda il boot di windows:


CASO 1:

nel pc 1 ho 2 hd:

hda, suddiviso in:
hda1 (ntfs 103gb con windows)
hda2 (ntfs 50 gb con windows)

hdb, suddiviso in
hdb1 (ext3 36 gb con linux (/))>>>(ubuntu 7.0.4 I386)
hdb2 (swap 2 gb)

linux non mi da problemi di funzionamento, ma windows non mi parte; il punto che ho provato ad inserire il disco di xp ed entrare nella console (comando R) per fare un fixmbr, ma, secondo il cd, sul computer non c' alcuna versione di windows. Cosa devo fare?

NB: Linux legge tranquillamente tutti i dati delle 2 partizioni ntfs



CASO 2:

sull'unico hd ho le partizioni:

hda1 (ntfs con windows, 74 gb)
hda2 (ext3 con ubuntu (/), 70 gb)>>>>(ubuntu 7.0.4 AMD64)
hda3 (swap)

premettendo che su questo disco avevo installato acronis os selector, il problema questo:


dopo aver installato ubuntu con grub in hd0 linux mi parte senza problemi; windows invece no.
a questo punto ho provato a ripristinare il bootloader con acronis disk os selector (grazie ad una chiavetta usb che avevo creato per sicurezza), e quindi il bootloader mi si ripristinato, ma quando tento di far partire windows, il quale appare correttamente nella lista dei sistemi presenti sul pc, questo mi rimanda ad una schermata nera con un trattino lampeggiante e da li non si smuove.
Il cd di xp mi riconosce la partizione e riconosce anche la presenza di windows all'interno di esso. Ho provato quindi a fare il fixmbr ed il fixboot, ma quando riavvio mi appare sullo schermo MBR error...
cosa devo fare?

NB. Anche in questo caso linux legge la partizione di win






grazie x l'aiuto!!! :dh: :dh: :dh: :dh: :dh:

Sembrerebbe il classico caso di partizione xp con il file di sistema 'ntldr' corrotto.
Recuperarlo dal cdrom installazione , tramite ubuntu (devi avere cabextract installato) , estrarlo tramite cabextrct e copiarlo direttamente nella radice della partizione XP.

paolone919191
13-08-2007, 09:55
scusa. ma da quale cabinet del cd lo devo estrarre??? (intendo da che file e in che posizione si trova sul cd)


inoltre ho installato il tool cabextract in linux, ma nn conosco i comandi...

mi puoi mandare una stringa di esempio???


thanks :D :D :D :D

paolone919191
13-08-2007, 18:06
ok, ho risolto il caso del 2 pc:

ho copiato i file ntldr e ntdetect.com dal cd (contenuto in cdrom\i386) in C:

ora il 2 funzia....



.....x il primo vedr al + presto poxibile......




THANKS!!!! :yuppi: :yuppi: :yuppi: :yuppi:

Loading