PDA

Visualizza la versione completa : [gentoo] reemerge kdenetwork


sacarde
20-08-2007, 21:29
ciao,
stavo provando gentoo, mi rendo conto che non e' facile da installare....

l'ho installata, ho installato xorg, ...
nell'installazione di kde ho:

* checking kdenetwork-3.5.7.tar.bz2 ;-) ... [ ok ]
* checking kdenetwork-3.5-patchset-01.tar.bz2 ;-) ... [ ok ]
*
* QA Notice: USE Flag 'kernel_linux' not in IUSE for kde-base/kdenetwork-3.5.7
* To support Video4Linux webcams in this package is required to have
* =x11-libs/qt-3* compiled with OpenGL support.
* Please reemerge =x11-libs/qt-3* with USE="opengl".

!!! ERROR: kde-base/kdenetwork-3.5.7 failed.
Call stack:
ebuild.sh, line 1648: Called dyn_setup
ebuild.sh, line 714: Called qa_call 'pkg_setup'
ebuild.sh, line 44: Called pkg_setup
kdenetwork-3.5.7.ebuild, line 57: Called die

!!! Please reemerge =x11-libs/qt-3* with USE="opengl".
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/kde-base/kdenetwork-3.5.7/temp/build.log'.



premesso che di opengl non me ne importa nulla.... come potrei rimediare ?


grazie

andy caps
20-08-2007, 21:38
USE="opengl" emerge x11-libs/qt-3 kdenetwork :bh: non c' molto da fargli

altrimenti prova a mettere -opengl nelle use

sacarde
20-08-2007, 21:46
ma se metto -opengl

devo ricompilare tutto Xorg ?

andy caps
20-08-2007, 21:51
se lo avevi nelle use puo darsi

prova a dare un

emerge -Np --deep world dopo avere cambiato le use

GreyFox86
21-08-2007, 10:23
Se vuoi attivare una flag per uno specifico pacchetto ti consiglio di inserirla in /etc/portage/package.use, usando questa sintassi:
x11-libs/qt tutte le flag che vuoi
in questo modo non ti devi preoccupare di indicarle ogni volta che devi reinstallare il pacchetto.


Originariamente inviato da sacrade
stavo provando gentoo, mi rendo conto che non e' facile da installare....

La prima installazione e configurazione una bella botta, ma non mollare: una volta che impari a gestirla come si deve ti ci trovereai benissimo ;)

sacarde
21-08-2007, 16:33
Originariamente inviato da GreyFox86
Se vuoi attivare una flag per uno specifico pacchetto ti consiglio di inserirla in /etc/portage/package.use, usando questa sintassi:
x11-libs/qt tutte le flag che vuoi
in questo modo non ti devi preoccupare di indicarle ogni volta che devi reinstallare il pacchetto.



La prima installazione e configurazione una bella botta, ma non mollare: una volta che impari a gestirla come si deve ti ci trovereai benissimo ;)

ho dato:

USE="opengl" emerge x11-libs/qt kdenetwork

ma dopo aver compilato qt mi ridice:

* checking kdenetwork-3.5-patchset-01.tar.bz2 ;-) ... [ ok ]
* QA Notice: USE Flag 'kernel_linux' not in IUSE for kde-base/kdenetwork-3.5.7
* To support Video4Linux webcams in this package is required to have
* =x11-libs/qt-3* compiled with OpenGL support.
* Please reemerge =x11-libs/qt-3* with USE="opengl".

!!! ERROR: kde-base/kdenetwork-3.5.7 failed.
Call stack:
ebuild.sh, line 1648: Called dyn_setup
ebuild.sh, line 714: Called qa_call 'pkg_setup'
ebuild.sh, line 44: Called pkg_setup
kdenetwork-3.5.7.ebuild, line 57: Called die

!!! Please reemerge =x11-libs/qt-3* with USE="opengl".
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/kde-base/kdenetwork-3.5.7/temp/build.log'.


aiuto ..... ( tanto per complicarla ... sono su una macchina powerpc G4)

GreyFox86
21-08-2007, 16:36
Forse non specificando la versione quel comando ti ha installato la versione 4 delle QT e quindi non ha riemerso la 3.
L'errore dice la versione 3, ricompila esplicitamente quella:

USE="opengl" emerge =x11-libs/qt-3* kdenetwork -ap

-p ti fa mostrare tutto quello che sta per fare in dettaglio, la -a sta per ask. Cos controlli che le versioni coincidano e che le use vengano impostate correttamente.

andy caps
21-08-2007, 19:47
la cosa migliore

USE="opengl" emerge x11-libs/qt-3
poi quando ha finito

emerge kdenetwork

semplicemente

GreyFox86
21-08-2007, 20:11
andy_caps senza un segno di uguale davanti al nome del pacchetto non puoi specificarne la versione. Inoltre per evitare di indicare la versione per esteso bisogna mettere un asterisco dopo il 3, cos: =x11-libs/qt-3*

:ciauz:

andy caps
21-08-2007, 21:19
:madai!?: si in effetti come dicevo io emerge le qt 4.3

Loading