PDA

Visualizza la versione completa : Aggiornamento pacchetti deb con synaptic


giorgiosironi88
22-08-2007, 01:46
Utilizzando synaptic, ho inserito i repository ufficiali debian (sarge). Così ho potuto aggiornare un paio di pacchetti (ncurses forse) che mi servivano per installare amule, che utilizzo tuttora.
Il fatto è che ora per quando tento di installare cups per far funzionare la stampante, e anche molti altri pacchetti, le dipendenze richiedono di disinstallare praticamente tutto il sistema (kate, quanta, xserver-xfree86 e tantissime libgnome* per fare un esempio) e di aggiornarne altri. Si tratta di centinaia di pacchetti e NON li toglierò mai.
Ho provato ad installare cups da sorgente, ma dopo ./configure e make restituisce un errore di cui google non sa nulla di "multiple definitions" di alcune funzioni. Come posso fare?
Grazie

andy caps
22-08-2007, 06:19
devi avere qualcosa di irregolare nel sources.list .

incollalo qui poi vediamo

adesso calcola che stable "etch" testing "lenny" old-stable "sarge "

Loading