PDA

Visualizza la versione completa : [Mandriva 2007 spring" Problema montaggio dischi


mykol
22-08-2007, 13:32
Ciao,

mentre stavo spostando dei file mancata la corrente. al riavvio, se cerco di smontare un disco dall'apposita finestra "Periferiche" cliccando sulla relativa icona non funziona e compare il seguente messaggio d'errore:

".... lo smontaggio fallito per il seguente motivo:


Device has /dev/hdc1 volume.ignore set to TRUE. Refusing to mount."

Se invece cerco di montarlo ho l'errore "Autorizzazioni negate".

Da console, come root, i comandi mount e umount /dev/hdc1 funzionano.

Cio, in sostanza non posso pi n montarlo n smontarlo da utente.

L'fstab il seguente:

/dev/hda6 / reiserfs notail,noatime 1 1
/dev/hdb /media/cdrom auto umask=0,users,iocharset=utf8,noauto,ro,exec 0 0
/dev/hdd /media/cdrom2 auto umask=0,users,iocharset=utf8,noauto,ro,exec 0 0
none /media/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=utf8,sync 0 0
/dev/hda1 /mnt/hda1 auto notail,noatime 0 0
/dev/hdc1 /mnt/dati auto notail,noatime 0 0
/dev/hdc2 /mnt/dati1 auto notail,noatime 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

e mi pare esattamente uguale a prima.

Qualche idea ?

grazie.

andy caps
22-08-2007, 14:22
/dev/hdc1 /mnt/dati auto auto,users,rw,umask=000 0 0

metti cosi fstab poi dovrebbe fartelo montare

mykol
22-08-2007, 16:16
si, lo so, anche nelle altre distro ho sempre messo quella stringa e funziona, ma non ho capito perch dopo quello spegnimento traumatico l'fstab che c' (che ha sempre funzionato) non funzioni pi !

L'fstab che ho postato sopra il suo, originale ed da quando l'ho installata che funziona perfettamente. Sta diventando una questione di principio.

mykol
22-08-2007, 16:40
ho risolto come mi hai suggerito, funziona perfettamente (come prima) ma mi piacerebbe capire perch ed il significato di quel messaggio d'errore !

mykol
22-08-2007, 22:36
nessuno ha qualche idea in merito ?

andy caps
22-08-2007, 22:42
vuol dire che nel cash ha settato in un file (non so quale ) la variabile
volume.ignore = TRUE mentre prima era volume.ignore = FALSE

possono essere molti i files

mykol
23-08-2007, 00:34
fortuna che come abbiamo modificato fstab funziona tutto perfettamente.

Grazie

Loading