PDA

Visualizza la versione completa : ubuntu e hd esterno


mxa
28-08-2007, 19:16
Mi hanno regalato un hd esterno da 160Gb della LACIE.
Quando lo attacco alla porta usb ubuntu lo vede correttamente, ma quando vado per smontarlo (pulsante destro, eject o espelli) mi dice che non può smontarlo perchè ci sta scrivendo.
Se invece da shell faccio
sudo umount /media/LACIE me lo smonta senza problemi e scompare l'icona dal desktop.

Come mai?

sacarde
29-08-2007, 10:37
se esegui il comando senza sudo ?


p.s.
sembra che l'utente non sia abilitato al montaggio smontaggio

mxa
29-08-2007, 18:30
se lo eseguo senza sudo mi dice che il dispositivo non sta in fstab e no sono root.
Ma è strano, perché con l'HD esterno usb dovrebbe essere la stessa cosa che con una chiavetta usb.O no??

sacarde
29-08-2007, 18:36
con la chiavetta funziona bene ?

strano...

mostri l'fstab

mykol
29-08-2007, 19:01
a me su mandriva 2007 spring più o meno succede la stessa cosa.

Ho preso un HD esterno USB da 350 GB e l'ho partizionato in 1 partizione formattata in HFS ed una seconda in EXT3.

Ora con una installazione di mandriva ho modificato a mano l'fstab e funziona.

Nell'altra il sistema ha aggiunto ad /etc/fstab le seguenti righe

LABEL=HD-USB1 /HD-USB1 xfs umask=000,users 0 0
LABEL=HD-USB2 /HD-USB2 ext3 umask=000,users 0 0

(HD-USB1 e HD-USB2 sono le "label" che ho assegnato al disco in fase di formattazione)

Il problema è che per fargli riconoscere l'HD devo staccarlo e collegarlo a caldo, ma in questo modo, all'inizio del boot, si ferma per un paio di minuti a cercare questa periferica.

Il fatto che si basi sulla "LABEL" per effettuare il montaggio è positivo, in quanto il device non cambia mai, ma tutte le volte bisogna scollegarlo e ricollegarlo ed è abbastanza scomodo.
Inoltre ho una chiavetta USB che invece viene montata normalmente.

Inoltre non potevo montarle graficamente come utente, ma sempre come utente, solo da linea di comando.

A questo ho ovviato, avviando konqueror da console di root, visualizzando le icone dei dischi in /media e settandololi /read/write da parte del proprietario, del gruppo, e degli altri utenti.

Una cosa che non capisco è perchè se li monta in /media, nelle righe di cui sopra in fstab non c'è traccia di /media, ma vengono direttamente montate in "/".

Chi ci capisce qualcosa ?

Per ora ho risolto (per modo di dire) in questo modo, ma il fatto di dover staccare il cavo prima del boot e riattarlo a sistema avviato non mi piace.

Qualche idea ?

Grazie.

mykol
29-08-2007, 20:15
ho risolto (più o meno) semplicemente ... cambiando la porta USB alla quale è connesso l'HD.

Ora monta le due partizioni in r/w e la possono montare/smontare anche gli utenti.

Qui le righe relative in fstab

/dev/sdb1 /mnt/HD-USB1 xfs noauto,users,rw,umask=000 0 0

#LABEL=HD-USB1 /mnt/HD-USB1 xfs umask=000,users 0 0

/dev/sdb2 /mnt/HD-USB2 ext3 noauto,users,rw,umask=000 0 0

Comunque ci voglio smanettare ancora un pò, mi piace troppo la comodità della "LABEL".

Altra cosa: quando spengo esce mi fa fare il login, devo entrare come root e dare halt.

Chissà cosa ha combinato questo maledetto HD.

mykol
29-08-2007, 20:28
praticamente ho risolto. In fstab ho commentato le righe relative all'HD USB ed ho riavviato.
Funziona perfettamente ed in fstab non ha messo nulla, ma le istruzioni necessarie le mette direttamente in /etc/mtab.

[giorgio@mandriva_2007_spring ~]$ cat /etc/mtab
/dev/hda6 / reiserfs rw,noatime,notail 0 0
none /proc proc rw 0 0
none /media/floppy supermount rw,sync,dev=/dev/fd0,fs=ext2:vfat,-- 0 0
/dev/hdc1 /mnt/dati reiserfs rw,noexec,nosuid,nodev,users 0 0
/dev/hdc2 /mnt/dati1 reiserfs rw,noexec,nosuid,nodev,users 0 0
/dev/hda1 /mnt/hda1 reiserfs rw,noexec,nosuid,nodev,users 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
/dev/sda1 /media/HD-USB1 xfs rw,nosuid,nodev,sync,uhelper=hal 0 0
/dev/sda2 /media/HD-USB2 ext3 rw,nosuid,nodev,sync,uhelper=hal,data=ordered 0 0
[giorgio@mandriva_2007_spring ~]$

Cioè li monta direttamente in /media con l'etichetta che gli avevo dato durante la formattazione. Ottimo.

Morale: se si usano gli strumenti automatizzati, bisogna lasciarli fare !

E prima di incominciare a smanettare con file di configurazione è bene controllare l'HW !

sacarde
29-08-2007, 21:32
e l'ultimo chiuda la po'lta

mxa
02-09-2007, 04:01
ecco il mio fstab


# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda3
UUID=9397ab39-8cab-4ee1-8e8b-64cae14b1d55 / reiserfs notail 0 1
# /dev/sda1
UUID=FC64EE7264EE2ED8 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda5
UUID=44D1-3381 /media/sda5 vfat defaults,utf8,umask=007,gid=46 0 1
# /dev/sda4
UUID=34425895-11d4-4a80-b1f5-7483daee31b9 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0


e per sicurezza anche l'mtab


/dev/sda3 / reiserfs rw,notail 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
/sys /sys sysfs rw,noexec,nosuid,nodev 0 0
varrun /var/run tmpfs rw,noexec,nosuid,nodev,mode=0755 0 0
varlock /var/lock tmpfs rw,noexec,nosuid,nodev,mode=1777 0 0
procbususb /proc/bus/usb usbfs rw 0 0
udev /dev tmpfs rw,mode=0755 0 0
devshm /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
lrm /lib/modules/2.6.20-16-generic/volatile tmpfs rw 0 0
/dev/sda1 /media/sda1 ntfs rw,nls=utf8,umask=007,gid=46 0 0
/dev/sda5 /media/sda5 vfat rw,utf8,umask=007,gid=46 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
/dev/sdb1 /media/LACIE vfat rw,nosuid,nodev,shortname=mixed,uid=1000,utf8,umas k=077 0 0

Loading