PDA

Visualizza la versione completa : finestre nere nvidia AIGLX


iraiscoming223
01-09-2007, 14:48
Ciao a tutti (eh si, di nuovo!). Ho disabilitato compiz fusion da qualche tempo per via delle finestre nere che comparivano di tanto in tanto fino a quando non venivano ridimensionate.. stato risolto questo problema che voi sappiate? Credo che il problema non stia n in xorg n in aiglx, ma forse proprio fusion e il suo modo di fare il rendering delle finestre che fa cilecca di tanto in tanto. So che capita solo con nvidia, se ne sapete qualcosa potreste informarmi xfav? Grazie mille!! :)

Tommy Snello
01-09-2007, 14:58
a me con nvidia e gli ultimi driver non lo fa

iraiscoming223
01-09-2007, 15:07
Originariamente inviato da Tommy Snello
a me con nvidia e gli ultimi driver non lo fa

ma te l'ha mai fatto prima? intendo magari con alcuni drivers vecchi... io uso quelli delle repo... -.-

Grazie 1000 x la risposta! ;)

p.s. (che scheda hai? io un go 6600)

GunMan
01-09-2007, 15:19
questo (http://ramielinux.wordpress.com/2007/07/07/finestre-nere-in-compiz-fusion/) articolo mi pare calzante, tra l'altro la parte finale indica chiaramente che i responsabili di questa anomalia sono proprio i driver dei repository che sono pi vecchi rispetto a quelli scaricabili dal sito nvidia.

la soluzione potrebbe essere, come ha suggerito Tommy Snello, aggiornare i driver.

:ciauz:

iraiscoming223
01-09-2007, 15:25
Originariamente inviato da GunMan
questo (http://ramielinux.wordpress.com/2007/07/07/finestre-nere-in-compiz-fusion/) articolo mi pare calzante, tra l'altro la parte finale indica chiaramente che i responsabili di questa anomalia sono proprio i driver dei repository che sono pi vecchi rispetto a quelli scaricabili dal sito nvidia.

la soluzione potrebbe essere, come ha suggerito Tommy Snello, aggiornare i driver.

:ciauz:

wow grazie a tutti e due! adesso aggiorno e vi dico! ;)

iraiscoming223
01-09-2007, 17:22
ho sputtanato la mia feisty... -.- (spero che i moderatori mi passino il termine)...

ho fatto il backup di xorg.conf prima di lanciare l'installazione, ho lanciato l'installazione (non so perch mi ha voluto ricompilare gli header del kernel - diceva di non trovare lo schermo o.O) e ora non parte pi X, n con un kernel, n con gli altri, n con l'xorg.conf aggiornato, n con quello precedente....

:(

Che fare?
ho gi provato i dpkg-reconfigure con gli nvidia-*, ma non servito a nulla... :cry: :cry:

Meskalamdug
01-09-2007, 17:53
Si tratta di un bug di nvidia
,a quello che mi risulta..non
ancora stato fixato.

Gionnico
01-09-2007, 18:07
Originariamente inviato da iraiscoming223
ho sputtanato la mia feisty... -.- (spero che i moderatori mi passino il termine)...

ho fatto il backup di xorg.conf prima di lanciare l'installazione, ho lanciato l'installazione (non so perch mi ha voluto ricompilare gli header del kernel - diceva di non trovare lo schermo o.O) e ora non parte pi X, n con un kernel, n con gli altri, n con l'xorg.conf aggiornato, n con quello precedente....

:(

Che fare?
ho gi provato i dpkg-reconfigure con gli nvidia-*, ma non servito a nulla... :cry: :cry:
Installazione dei drivers nVidia proprietari? Compiz fusion non ce l'hai messo ancora?
Prima che drivers utilizzavi??

iraiscoming223
02-09-2007, 21:46
Originariamente inviato da Gionnico
Installazione dei drivers nVidia proprietari? Compiz fusion non ce l'hai messo ancora?
Prima che drivers utilizzavi??

Prima usavo i drivers delle repo... :(


Originariamente inviato da
Meskalamdug
Si tratta di un bug di nvidia
,a quello che mi risulta..non
ancora stato fixato.

E questi str....astimpaticoni mettono in giro drivers profondamente instabili? C' un modo per tornare indietro senza backup e reinstalla? Per ora sto usando freespire, ma non sono abituato e non ho nemmeno tanto tempo da sbatter via... :(

Tommy Snello
02-09-2007, 22:13
prova a disinstallare tutti i pacchetti nvidia

p nvidia-glx - NVIDIA binary XFree86 4.x/X.Org driver
p nvidia-glx-dev - NVIDIA binary XFree86 4.x/X.Org driver dev
p nvidia-glx-legacy - NVIDIA binary XFree86 4.x/X.Org 'legacy' d
p nvidia-glx-legacy-dev - NVIDIA binary XFree86 4.x/X.Org 'legacy' d
p nvidia-glx-new - NVIDIA binary XFree86 4.x/X.Org 'new' driv
p nvidia-glx-new-dev - NVIDIA binary XFree86 4.x/X.Org 'legacy' d
v nvidia-kernel-1.0.7184 -
v nvidia-kernel-1.0.8774 -
v nvidia-kernel-1.0.9631 -
v nvidia-kernel-1.0.9755 -
p nvidia-kernel-common - NVIDIA binary kernel module common files
p nvidia-kernel-source - NVIDIA binary kernel module source
p nvidia-legacy-kernel-source - NVIDIA binary 'legacy' kernel module sourc
p nvidia-new-kernel-source - NVIDIA binary 'new' kernel module source
p nvidia-settings - Tool of configuring the NVIDIA graphics dr
p nvidia-xconfig - The NVIDIA X Configuration Tool

e dopo reinstalla i driver 100.14.11

ah prima ricordati di installare gli strumenti di compilazione build-essential e gcc

Loading