PDA

Visualizza la versione completa : wireless su debian


bonzox
10-09-2007, 17:36
Ho installato Etch sul portatile hp zv6000 e ora vorrei configurare la scheda di rete e navigare sulla rete wireless.

Con mandriva dal control Center ero riuscito con i Driver di Windows.

Con un file bcmwl5.inf

Su Debian ho installato ndigtk

http://linuxappfinder.com/package/ndisgtk

http://http.us.debian.org/debian/pool/main/n/ndisgtk/ndisgtk_0.7.2-1_i386.deb

Desktop -> amministrazione -> windows wireless drivers
e ho messo il nuovo driver.

ho configurato il network e Ora per non riesco a connettermi.

iwconfig mi dice:


lo no wireless extensions.

eth2 no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11b/g ESSID:"ilbonzo" Nickname:"Broadcom 4306"
Mode:Managed Access Point: Invalid
RTS thr:off Fragment thr:off
Encryption key:636F-6E6E-6574-7469-6D65-6C6F-00 Security mode:open
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

nathan:/home/bonzo#

hfish
10-09-2007, 19:07
Originariamente inviato da bonzox
Ho installato Etch sul portatile hp zv6000 e ora vorrei configurare la scheda di rete e navigare sulla rete wireless.

Con mandriva dal control Center ero riuscito con i Driver di Windows.

Con un file bcmwl5.inf

Su Debian ho installato ndigtk

http://linuxappfinder.com/package/ndisgtk

http://http.us.debian.org/debian/pool/main/n/ndisgtk/ndisgtk_0.7.2-1_i386.deb

Desktop -> amministrazione -> windows wireless drivers
e ho messo il nuovo driver.

ho configurato il network e Ora per non riesco a connettermi.

iwconfig mi dice:


lo no wireless extensions.

eth2 no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11b/g ESSID:"ilbonzo" Nickname:"Broadcom 4306"
Mode:Managed Access Point: Invalid
RTS thr:off Fragment thr:off
Encryption key:636F-6E6E-6574-7469-6D65-6C6F-00 Security mode:open
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

nathan:/home/bonzo#

la rete a cui vuoi connetterti protetta da wep/wpa?
che essid ha la rete? previsto il dhcp? insomma... altre info :)

bonzox
11-09-2007, 09:20
Originariamente inviato da hfish
la rete a cui vuoi connetterti protetta da wep/wpa?
che essid ha la rete? previsto il dhcp? insomma... altre info :)

hai ragione, scusa.

Rete ssid ilbonzo
protetta con chiave WPA-PSK

p.s. OT mille post... grazie a tutti per l'aiuto

hfish
11-09-2007, 09:27
allora...

dai un


iwlist eth1 scan

e l'output dovrebbe essere *simile* a questo


root@v2410:/home/hfish# iwlist eth1 scan
eth1 Scan completed :
Cell 01 - Address: 00:13:49:1D:86:40
ESSID:"ZyXEL"
Protocol:IEEE 802.11bg
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 22 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Quality=73/100 Signal level=-61 dBm Noise level=-61 dBm
Extra: Last beacon: 86ms ago

root@v2410:/home/hfish#

in caso positivo riesci a rilevare la rete, in caso negativo ci sono grossi problemi..

detto questo, se riesci a vedere la rete e se lo puoi fare, prova a disabilitare la crittazione del wifi... a questo punto, presumendo che ci sia un server dhcp atttivo, dai da root


iwconfig eth1 essid ilbonzo
dhclient eth1

dovresti esserci...

se tutto funziona a dovere sei a buon punto... riabilita il wpa e segui uno dei mille tutorial in rete per configurare wpa supplicant (uno su tutti http://www.google.com/search?hl=it&safe=off&q=wpa-supplicant+debian+how+to&btnG=Cerca&lr=lang_it )

se ci dovessero essere problemi siamo qui :)
ciao

bonzox
11-09-2007, 09:54
Originariamente inviato da hfish
allora...

dai un


iwlist eth1 scan


nathan:/home/bonzo# iwlist eth1 scan
eth1 Interface doesn't support scanning : No such device
mi da questo.
ho visto che se attivo l'intefaccia di rete me la attiva, ma quando riapro e guardo non pi attiva.

hfish
11-09-2007, 09:58
Originariamente inviato da bonzox
nathan:/home/bonzo# iwlist eth1 scan
eth1 Interface doesn't support scanning : No such device
mi da questo.
ho visto che se attivo l'intefaccia di rete me la attiva, ma quando riapro e guardo non pi attiva.

non ho ben capito la frase in grassetto... in ogni caso se la scheda di rete nn attiva, abbastanza normale che non vengano rilevate reti :)

bonzox
11-09-2007, 10:05
se vado in Desktop -> amministrazione -> rete

e faccio attiva sulla interfaccia wireless eth1 me la attiva, o almeno scrive cos.
Poi faccio ok.

Se riapro non pi attiva...

Loading