PDA

Visualizza la versione completa : problema nvidia-glx


hfish
17-09-2007, 20:28
ciao a tutti
uso debian sid con driver nvidia ricompilati nel kernel

oggi ho dato un apt-get dist-upgrade con conseguente aggiornamento di xorg-* e xserver-xorg-*... al riavvio del pc X non partiva pi lamentando di non riuscire a caricare il modulo nvidia... tale modulo, secondo lsmod, era correttamente caricato

una volta risolsi lo stesso problema installando nvidia-glx, e quindi ho dato un bel apt-get install nvidia-glx -y --force-yes e sono andato in bagno... al ritorno con mia sommo piacere ho visto che nvidia-glx mi aveva disinstallato xorg e xserver-xorg-* :oVVoVe: :oVVoVe: :oVVoVe:

lurkando un po' ho trovato questo
http://osrevolution.wordpress.com/2007/09/17/linarrestabile-avanzata-debian-xorg-73-e-nvidia-driver-closed/

ho i problemi riportati nei post 9, 10 e 11...

qualche suggerimento?

grazie
ciao

jaso
17-09-2007, 20:38
Anche io ho riscontrato i tuoi stessi problemi per purtroppo non s come risolvere. Cmq questo il bello di "sid".

hfish
17-09-2007, 21:08
Originariamente inviato da jaso
Anche io ho riscontrato i tuoi stessi problemi per purtroppo non s come risolvere. Cmq questo il bello di "sid".

bello una sega :nonlodire
a sto punto speriamo che nvidia rilasci un aggiornamento in tempi utili...

jaso
17-09-2007, 21:13
era per dire.. cmq NON funzionano nemmeno i driver "nv" !!

hfish
17-09-2007, 21:15
a me si...

se provi ad installare nvidia-glx ti toglie xserver-xorg-*?
hai errori di post-inst se provi a reinstallare xorg?

andy caps
17-09-2007, 21:40
dovrebbero uscire questi driver nuovi a brevissimo


con i driver nvidia va facendo delle modifiche a gdm.conf o kdmrc se usi kde

qualche problema comunque rimane e probabilmente rimarra anche con i driver nuovi con composite e xinerama

con i driver nvidia installati basta aggiungere alla riga 474 -ignoreABI in fondo

ServerArgsLocal=-nolisten tcp -ignoreABI


per gdm alla riga 566 probabilmente

command=/usr/bin/X -audit 0 -ignoreABI

gdm dovrebbe essere testato :bh:


con i driver propri di debian probabilmente dovrai aspettare che sistemino loro


io naturalmente ho dato il dist-upgrade direttamente ed aggiornato tutto

hfish
17-09-2007, 22:01
il problema che se installo nvidia-glx mi viene disinstallato xorg, e quindi startx mi muore miseramente dicendomi che /usr/bin/X non eseguibile... grazie al cazzo! non esiste proprio!!

andy caps
17-09-2007, 22:16
si probabilmente devi aspettare gli aggiornamenti di domani

quelli di debian sistemeranno domani o dopodomani
io nvidia-glx non l'ho installato

con i driver binari nvidia si deve proprio purgare e rimuovere tutto i pacchetti nvidia di apt

a me va tutto tranquillamente anche se compiz qualche rallentamento ce l' ha

http://osrevolution.wordpress.com/2007/09/17/linarrestabile-avanzata-debian-xorg-73-e-nvidia-driver-closed/

su osrevolution qualche rimedio lo hanno trovato

puoi provare a rimuovere tutto nvidia ed installare i driver magari con qualche opzione tipo

sh NV* --no-abi-note

ma non detto che te li installi

mmbarabba
18-09-2007, 10:14
prova a dare un'okkio qui (http://www.nervous.it/hw/linux_aspire1300xv.html)


per avviare x in modo provvisorio usa il comando :

startx -- -ignoreABI

se invece vuoi inserirlo in KDM , aggiungi
verso la fine di /etc/X11/xinit/xserverrc :

exec /usr/bin/X11/X -dpi 100 -nolisten tcp -ignoreABI


oTTo ieri sera ha risolto cosi con i driver 100.xx su debian sid
dopo l'upgrade

:unz:
altrimenti tocca aspettare

hfish
24-09-2007, 00:39
hanno appena messo i nuovi nvidia-kernel-source 100.14.19-1 in sid... sto ricompilando... speriamo torni tutto a funzionare, va :dh:

edit: kernel ricompilato e tutto fila liscio come l'olio :D

Loading