PDA

Visualizza la versione completa : Conflitti di IRQ / IO


Visionario
18-09-2007, 14:07
Salve a tutti,

una macchina linux (ex Mandrake 9.1 aggiornata a Mandrivia) che funziona da circa 5 anni, dà segni di squilibrio :D
La scheda madre dopo uno sbalzo di corrente ha dato un messaggio che in poche parole diceva:

"Spegnimento non corretto il sistema partirà con i valori di default".

Da quel momento la scheda di rete, le porte USB sono integrate sulla scheda madre. Al momento del BOOT linux mi mostra questo messaggio:

"insmod Errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters "
me lo elenca mosta 3 volte sui moduli: USB-UHCI, la rete, e un altro che non ricordo.

Come si può ripristinare il corretto funzionamento? Almeno della Scheda di rete, ora la periferica eth0 non funziona, anzi non la trova proprio.
In questo momento mi viene una domanda, se acquisto un'altra scheda di rete? Potrebbe funzionare?

Saluti

mykol
18-09-2007, 15:13
Ovviamente si è verificato un danno all'Hardware, oppure al software.

Per verificare qual'é mche non funziona potresto provare con una distro "live" (es. una Knoppix od una Mandriva ONE) o, ancor prima, osservare i messaggi che ti da al boot, per vedere se avviene il riconoscimento della scheda ethernet.

Forse potresti trovare qualcosa anche nel file /var/log/messages

Es. in console come root

cat /var/log/messages |grep eth

cat /var/log/messages |grep Ethernet

oppure

lspci |grep Ethernet

A me ad esempio esce

# lspci |grep Ethernet
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)


Se la scheda viene vista bisogna controllare se carica i moduli necessari e se non sono danneggiati.

Visionario
18-09-2007, 19:43
Grazie per i consigli vedo che mi hai capito al volo, ho lanciato il comando "lspci | grep Ethernet" e mi ha restituito questo:

00:04.0 Ethernet controller nVidia Corporation nForce2 Ethernet controller (rev a1)

quidi presuppongo che la scheda di rete la vede ma non riesce a caricare il modulo?
come devo proseguire ora?

ATHRAF
19-09-2007, 11:37
Se dopo un riavvio o dopo uno sbalzo di corrente il bios carica i fattori di default la prima cosa è capire che scheda madre è e sopratutto entrare nel bios e controllare le impostazioni dei dispositivi (pci, agp ecc), ci sono infatti schede vecchiotte ad es che se imposti plug and play os su yes non riescono ad indirizzare correttamente irq o meglio è il so che non riesce a interpretare come ha indirizzato il tutto..
Questo te lo dico come esempio poi sta a te vedere che scheda madre hai e documentarti possibilmente su qualche forum o su questo trovi info a riguardo ma sopratutto sta attento ai sovraccarichi se non compri un ups di buona marca e di media potenza rischi di bruciare tutto.
Un apc o riello da almeno 800va che forniscono sia protezione attiva da sovraccarichi che batterie sufficientemente potenti per alimentare al meglio almeno pc e monitor 19, unica pecca sono i prezzi superiori cmq ai 100 € ma ti assicuro che sono soldi ben spesi...

:ciauz:

Loading