PDA

Visualizza la versione completa : configurare server


bonzox
01-10-2007, 18:42
Ho preparato una macchina virtuale che metto on-line solo come prova.

E' debian con apache2

sono dietro ad un firewall monowall ed ho un ip pubblico.

Ora il problema è che riesco a vedere la pagina di apache "it works" anche da fuori, per esempio con anonymouse.

Però non riesco avedere le sottocartelle.
in var/www ho fatto una cartella prova con una pagina index.html.

Da locale la vedo in localhost/prova

Ma da fuori mi dice che non è raggiungibile.

Il problema secondo voi è monowall o apache? e soprattutto che errore ho fatto?

andy caps
01-10-2007, 19:43
controlla che permessi ha la cartella

moskitoita
01-10-2007, 21:00
Devi togliere dal file di configurazione "RedirectMatch ^/$ /apache2-default/" altrimenti la root del server viene spostata in /var/www/apache2-default

bonzox
02-10-2007, 09:09
i permessi sono questi:

Cartelle:

drwxr-xr-x 2 root root 4096 2007-10-01 20:24 apache2-default
drwxr-xr-x 2 root root 4096 2007-10-01 19:22 prova

file:
-rw-r--r-- 1 root root 14 2007-10-01 19:22 index.html


Ma se da locale lo vedo e da remoto no, può essere il problema del redirect? :master:

bonzox
02-10-2007, 09:19
NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
# This directive allows us to have apache2's default start page
# in /apache2-default/, but still have / go to the right place
RedirectMatch ^/$ /
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>
<Directory "/basket">
</Directory>

</VirtualHost>

Ho modificato questa riga:
RedirectMatch ^/$ /apache2-default/

con

RedirectMatch ^/$ /

Ma da fuori non lo vedo comunque...

questo è l'errore:

Not Found

The requested URL /prova was not found on this server.
Apache/2.2.3 (Debian) mod_python/3.2.10 Python/2.4.4 PHP/5.2.0-8+etch7 mod_perl/2.0.2 Perl/v5.8.8 Server at ********* Port 80

moskitoita
02-10-2007, 16:00
Stesso errore anche con indirizzo ip/prova/index.html ?

bonzox
02-10-2007, 16:13
Io uso l'ip
non ho registrato nessun dominio

Se vedo da fuori http://xxx.xxx.xxx.xxx/prova non va

da dentro http://192.168.1.33/prova va

Lo faccio da una macchina della rete interna

moskitoita
02-10-2007, 16:43
Non puoi pensare di contattare il tuo ip esterno da una macchina interna; a meno che tu non stia usando un proxy...

Comunque puoi togliere un po' di fronzoli dalla configurazione:


NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/
<Directory />
Options Indexes FollowSymLinks MultiViews
AllowOverride None
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

</VirtualHost>

mark2x
02-10-2007, 17:03
Originariamente inviato da bonzox
Io uso l'ip
non ho registrato nessun dominio

Se vedo da fuori http://xxx.xxx.xxx.xxx/prova non va

da dentro http://192.168.1.33/prova va

Lo faccio da una macchina della rete interna

Ti è stato chiesto (molto giustamente) se con : http://xxx.xxx.xxx.xxx/prova/index.html [o .htm] dall'Internet funziona o meno...

Infine aggiungo che fare un semplice NAT come hai fatto tu non è la cosa giusta se hai anche solo 2 server Web, nel qual caso dovresti usare un reverse proxy. Ma questo non c'entra nulla col tuo problema, era solo una precisazione.

mark2x
02-10-2007, 17:04
Sulla config. che ti è stata proposta, poi, io toglierei gli alias e metterei un bel Options None su /, oltre che una signature ad off.
Ma poi in verità ci sarebbe da sbizzarrirsi...

Loading