PDA

Visualizza la versione completa : [DEBIAN] Rete cablata, ma non riesco a navigare


Downloader
05-10-2007, 18:37
Avevo gi aperto un vecchio thread su questo argomento, solo che non riuscii a risolvere il mio problema, ci riprovo!

Sistema operativo: Debian etch
Modem/Router: NetGear DG632 (attacco eth)
Problema: impossibile accedere alla rete nonostante GNOME indichi che la rete cablata.

Stranamente con lo stesso sistema installato quando usavo Konqueror potevo navigare senza problemi, con altri software (browser alternativi e software di posta) no, neanche l'aggiornamento dei pacchetti andava, stranamente Skype funzionava e faceva il suo dovere .

La configurazione che ho settato riguarda solamente la parte del router, i DNS vari sono settati dal router in maniera tale da doverseli procurare da solo e su windows tutto funziona a meraviglia.

Ora, una volta settati i parametri fondamentali in linea teorica non dovrebbe pi servire nulla e il modem/router dovrebbe su qualsiasi piattaforma funzionare senza ulteriori modifiche, ma cosi non e non capisco perch.

Mi date una mano??


Grazie

pilovis
05-10-2007, 18:40
se skype funziona ma il browser non naviga e' un problema di dns, perche' skype chiama direttamente l'IP del server per cui non ha bisogno dei dns

pilovis
05-10-2007, 18:45
digita nella barra indirizzi questo indirizzo IP 207.46.19.190 , se vedi il sito allora e' certamente un problema di DNS

Downloader
05-10-2007, 18:56
E se fosse cosi come devo comportarmi?

Devo aggiungere i DNS a resolv.conf?? E se li settassi direttamente sul router sarebbe lo stesso?

pilovis
05-10-2007, 19:04
Dipende, se sei in DHCP e il router fa da server DHCP allora i dns li devi settare sul router, altrimenti li devi mettere nel pc

francofait
05-10-2007, 19:09
:quote: :quote: l'indirizzo di microsoft :cry: :cry: :mame: :mame: un vale :D :D :malol:

pilovis
05-10-2007, 19:10
:mame:

vortex87
05-10-2007, 19:23
Magari basta aggiungere in /etc/resolv.conf "nameserver {ip del router}"

Downloader
05-10-2007, 19:30
Dunque, su resolv.conf ho questo:


# generated by NetworkManager, do not edit!!!

nameserver 192.168.0.1



e anche se provo a editare il file mettendo i dns di libero non cambia nulla.
Ho inserito i dns anche direttamente sul router, ma niente.

pilovis
05-10-2007, 19:35
prova nameserver 212.216.112.112

Loading