PDA

Visualizza la versione completa : hd esterno fat32, permessi, ubuntu 7.04


friul_hack
17-10-2007, 00:03
Ho un hd esterno, FAT32.. ma non riesco a copiare elimnare file ne niente perche mi dice: file system in sola lettura.. come posso fare?

Francis87
17-10-2007, 06:39
in /etc/mtab per il mio hd esterno ho:

/dev/sdb1 /media/My\040Book vfat rw,nosuid,nodev,noatime,flush,uid=1000,utf8,shortn ame=lower 0 0

trillullero
17-10-2007, 08:52
riporta anche
ls -l /media

Penso che tu stia provando a scrivere con un utente che non quello con user ID 1000 e i permessi di default siano 755.

raistlin76
17-10-2007, 09:43
Qui c' quello che ti serve:

http://wiki.ubuntu-it.org/Hardware/DispositiviPartizioni/MontarePartizioni/Fat

friul_hack
17-10-2007, 14:33
.. nn cambia nulla.. mi dice ancora disco in sola lettura, quindi nn posso scriverci.. aiutatemi!!!!!

trillullero
17-10-2007, 15:01
riporta anche
ls -l /media

Se vuoi essere aiutato segui le istruzioni.

Dopo aver modificato /etc/fstab come indicato nel wiki, hai smontato e rimontato la chiavetta?

Prova anche farlo a mano:
mount /dev/sda1 /media/usb -t vat -o users,umask=000

e di nuovo
ls -l /media/

friul_hack
17-10-2007, 15:10
root@l0c4lh0st:~# ls -l /media
totale 24
lrwxrwxrwx 1 root root 6 2007-10-04 12:50 cdrom -> cdrom0
drwxr-xr-x 2 root root 4096 2007-10-04 12:50 cdrom0
drwxr-xr-x 2 root root 4096 2007-10-17 13:28 hd1e
drwxr-xr-x 2 root root 4096 2007-10-17 00:13 hd2
drwxr-xr-x 2 root root 4096 2007-10-17 13:18 hd2e
drwxr-xr-x 2 root root 4096 2007-10-16 22:31 hde
drwxr-xr-x 2 root root 4096 2007-10-16 22:25 TREKSTOR
root@l0c4lh0st:~# mount /dev/sdb1 /media/hd1e -t vat -o users,umask=000
mount: unknown filesystem type 'vat'
root@l0c4lh0st:~# mount /dev/sdb1 /media/hd1e -t vfat -o users,umask=000
root@l0c4lh0st:~# ls -l /media/
totale 52
lrwxrwxrwx 1 root root 6 2007-10-04 12:50 cdrom -> cdrom0
drwxr-xr-x 2 root root 4096 2007-10-04 12:50 cdrom0
drwxrwxrwx 6 root root 32768 1970-01-01 01:00 hd1e
drwxr-xr-x 2 root root 4096 2007-10-17 00:13 hd2
drwxr-xr-x 2 root root 4096 2007-10-17 13:18 hd2e
drwxr-xr-x 2 root root 4096 2007-10-16 22:31 hde
drwxr-xr-x 2 root root 4096 2007-10-16 22:25 TREKSTOR
root@l0c4lh0st:~# gedit /etc/fstab


ecco....
il mio hd /dev/sdb1
e l'ho montato in /media/hd1e

trillullero
17-10-2007, 16:17
il mio hd /dev/sdb1
e l'ho montato in /media/hd1e

drwxr-xr-x 2 root root 4096 2007-10-17 13:28 hd1e

Come vedi solo l'utente root pu scrivere in hd1e.

Prima ho fatto un errore di battitura evidenziato dal messaggio

mount: unknown filesystem type 'vat'
andava"vfat".

Riesegui il procedimento del mount manuale

umount /dev/sdb1
mount /dev/sdb1 /media/hd1e -t vfat -o users,umask=000

Vedrai che sicuramente riuscirai a scrivere con qualsiasi utente e riuscirai anche a smontare la chiavetta con qualsiasi utente.

Al reboot questa impostazione va persa. Per questo devi editare correttamente /etc/fstab.
Riporta il suo contenuto cos lo possiamo verificare.

Ciao.

friul_hack
17-10-2007, 19:33
lo avevo capito che andava vfat. Ho rimontato cmq... ma non cambia niente. disco in sola lettura, e non posso farci niente. Rifacciamo tutto da capo ok? ridimmi bene cio che devo fare, e io lo faro. Grazie molto cmq per il tuo interesse ;)
quindi ridimmi bene cio che devo fare.. perche cmq nn riesco a scriverci ancora, avendo ftt cio che mi hai dtt... UFFA!!!!

friul_hack
17-10-2007, 19:36
Ora riporto cio che viene scritto dando: sudo fdisk -l


root@l0c4lh0st:~# sudo fdisk -l

Disk /dev/sda: 163.9 GB, 163928604672 bytes
255 heads, 63 sectors/track, 19929 cylinders
Units = cilindri of 16065 * 512 = 8225280 bytes

Dispositivo Boot Start End Blocks Id System
/dev/sda1 * 1 19742 158577583+ 83 Linux
/dev/sda2 19743 19929 1502077+ 5 Esteso
/dev/sda5 19743 19929 1502046 82 Linux swap / Solaris

Disk /dev/sdb: 400.0 GB, 400088456704 bytes
255 heads, 63 sectors/track, 48641 cylinders
Units = cilindri of 16065 * 512 = 8225280 bytes

Dispositivo Boot Start End Blocks Id System
/dev/sdb1 1 48641 390708801 c W95 FAT32 (LBA)
root@l0c4lh0st:~#

Ora cio che viene scritto in fstab..


# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
UUID=8a467742-a170-4397-840c-79ec0a3597d5 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda5
UUID=72257cd8-74e6-4529-a29d-cf2a78fd2b46 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/sdb1 /media/hd1e vfat iocharset=utf8,umask=000 0 0

ecco.. forse sbagliato questo: iocharset=utf8,umask=000 0 0 <=== magari qst mi crea i problemi, mag dovrei scriverci qualc di diverso..boh

Loading