PDA

Visualizza la versione completa : sendmail aiuto


gio79rc
26-10-2007, 15:25
Ciao raga
ho un problema con sendmail
ho installato sendmail in un macchina collegata in una lan ma quando invio l email ad un qualsisi indirizzo (ad esempio libero .it ecc) l email vengono inoltrate correttamente
ma quando invio l email al domino dell azienda dominio.it non me le inoltra?
cosa devo fare?
ciao e grazie

pilovis
28-10-2007, 00:59
il dominio dell'azienda dove risiede, su quella macchina in cui c'e' sendmail?

gio79rc
29-10-2007, 08:53
Il dominio dell azienda risiede su un altra macchina che fa parte sempre della lan.
Sulla macchina dove c sendmail non c' il server aziendale,il server aziendale si trova su una machina windows.
ciao a presto

pilovis
29-10-2007, 09:26
Se la LAN e' sotto NAT e' normale che non ti vede il dominio che risiede sulla stessa LAN, perche' i DNS risolvono il dominio con l'indirizzo IP pubblico e quando sei sotto NAT l'IP pubblico della tua connessione (e servizi associati) non e' raggiungibile dall'interno della LAN perche' le richieste si fermano sul router.
Dovresti inserire nel file di host di ogni macchina un record che risolva il dominio sull'indirizzo IP privato della macchina che gestisce il mailserver, bypassando cosi' la risoluzione del nome con i DNS

gio79rc
29-10-2007, 09:46
Ciao scusa ma ho poca esperinza doi reti, potrsti essere un p + chiaro?grazie e ciao

pilovis
30-10-2007, 09:12
http://www.andreabeggi.net/2005/09/15/tcpip-in-pillole-nat/

gio79rc
30-10-2007, 09:17
ciao ti spiego un p meglio come organizzata la mia lan
sulla lan ci sono 5 6 host tra cui il server aziendale, stamattina chiedendo al collega mi ha detto che il mail server si trova presso aruba e sul server che abbiamo in azienda, cio sulla lan non c il domino
nella mia macchina dove ho installato sendmail c come dns l indirizzo ip (192.xxx.xx.xx) del server aziendale
la rete lan comunica con l esterno attraverso un firewall con un IP pubblico statico
cosa devo fare per risolvere il problema con sendmail???
ciao e grazie

pilovis
30-10-2007, 09:35
l mail server si trova presso aruba e sul server che abbiamo in azienda

Cosa significa? C'e' un mailserver di backup sul server aziendale oppure quest'ultimo fa solo un fetching (scaricamento) della posta dal server principale?
E il mailserver di cui parli tu nel primo post (sendmail) cos'e', un altro mailserver ancora?

I dati che mi hai dato sono insufficienti per capire dove risiede il problema.
Occorrono molte piu' informazioni sulla tipologia della rete (classe, NAT o PAT, eventuali DMZ, ecc.), sui servizi installati sul server aziendale e come sono configurati, occorre conoscere come e' configurato il parametro MX (Mailer eXchange) dei DNS autoritativi del vosto dominio aziendale per vedere se c'e un server di backup, in questo ultimo caso il parametro sara' cosi':

esempio:
dominioaziendale.it. IN MX 10 mail.serveraruba.it. #mailserver principle su Aruba
dominioaziendale.it. IN MX 20 mail.serverinterno.it. #mailserver di backup interno sotto DMZ

pilovis
30-10-2007, 09:37
e poi mi serve il messaggio di errore che ti ritorna quando invii le mail al vostro dominio aziendale

gio79rc
30-10-2007, 09:40
il mail server si trova solo su aruba (ho sbagliato a scrivere)
ma quando dalla lan invio un email a altrodominio.it l email viene inoltrata
mentre quando dalla lan mando un email a dominio.it (dove domino.it il dominio aziendale) l email non viene inoltrata
ciao e grazie

Loading