PDA

Visualizza la versione completa : [Debian] Pacchetti bloccati?


MisterBean
30-10-2007, 19:06
Ciao a tutti. Ecco il casino.
Sabato ho cercato di installare sulla mia Debian il pacchetto "escputil", che mi ha dato non pochi problemi con le dipendenze. Oggi ho scoperto che il pacchetto escputil e libncurses5 sono segnati come difettosi da Synaptic...
Il bello è che non mi fa installare o rimuovere niente finchè non sistemo i pacchetti. La funzionalità di recupero dei pacchetti difettosi fallisce miseramente, e anche dando il comando apt-get -f install, l'output è il seguente:
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Correzione delle dipendenze in corso... fallita.
I seguenti pacchetti hanno dipendenze non soddisfatte:
escputil: Dipende: libc6 (>= 2.6-1) ma 2.3.6.ds1-13etch2 è installato
Dipende: libgutenprint2 (>= 5.0.1) ma 5.0.0-3 è installato
libncurses5: Dipende: libc6 (>= 2.6.1-1) ma 2.3.6.ds1-13etch2 è installato
E: Errore, pkgProblemResolver::Resolve ha generato uno stop, questo può essere causato da pacchetti bloccati
E: Impossibile correggere le dipendenze

Ordunque, come sistemare?
Altra domanda: si possono leggere file scritti con Lotus su Linux? (esiste una suite office che supporta tale formato)?

andy caps
30-10-2007, 20:53
non so cosa hai messo nel sources.list

se hai fatto un misto chiaramente prima devia aggiornare il sistema poi installare

libc6 >= 2.6-1 è sulla debian sid unstable non sulla etch

MisterBean
31-10-2007, 00:44
Ecco il contenuto di sources.list:

#
# deb cdrom:[Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 DVD Binary-1 20070819-11:33]/ etch contrib main

deb cdrom:[Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 DVD Binary-1 20070819-11:33]/ etch contrib main

# Line commented out by installer because it failed to verify:
#deb http://security.debian.org/ etch/updates main contrib
# Line commented out by installer because it failed to verify:
#deb-src http://security.debian.org/ etch/updates main contrib

andy caps
31-10-2007, 01:57
allora probabilmente cerchi diinstallare manualmente una versione errata del pacchetto

se hai una connessione veloce conviene mettere un server di etch almeno

deb http://debian.fastweb.it/debian/ stable main non-free contrib
deb-src http://debian.fastweb.it/debian/ stable main non-free contrib

cosi installa sicuramente i pacchetti corretti

alkat
31-10-2007, 03:43
Originariamente inviato da MisterBean
Altra domanda: si possono leggere file scritti con Lotus su Linux? (esiste una suite office che supporta tale formato)?

http://www.ossblog.it/post/1125/ibm-svela-lotus-notes-per-linux

Loading