PDA

Visualizza la versione completa : debian e moduli all'avvio del sistema


lion1810
04-11-2007, 12:19
Ragazzi per sentire l'audio sul vecchio portatile armada 1700 devo far partire i seguenti moduli:

modprobe sound
e

modprobe sb io=0x220 irq=5 dma=1 dma16=5

anzitutto non capisco una cosa :

normalmente una volta dati questi comandi automaticamente me li caricava all'avvio ... stavolta no ...
Allora li ho inseriti in /etc/modules

-------
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

loop

#aggiunte manualmente

sound
sb io=0x220 irq=5 dma=1 dma16=5
----------------

ma nisba

Huh

qualche idea???

sacarde
04-11-2007, 19:21
dentro modules metti i moduli

dentro modules.conf metti i parametri


http://a2.pluto.it/a294.htm

francofait
04-11-2007, 19:43
modprobe nomemodulo vale per la sola sessione lavoro attiva in corso , da sempre.

lion1810
05-11-2007, 09:36
:( :dottò:

>dentro modules metti i moduli

appunto questo è il mio file /etc/modules

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

loop

#aggiunte manualmente

sound
sb io=0x220 irq=5 dma=1 dma16=5


----

>modprobe nomemodulo vale per la sola sessione lavoro attiva in corso , da sempre.

si si Franco era solo l'esempio dei moduli caricati con la sessionene aperta.
Il file /etc/modules è quello sospra.

sacarde
05-11-2007, 10:00
sb io=0x220 irq=5 dma=1 dma16=5

lo devi mettere dentro modprobe.conf


http://linux.die.net/man/5/modprobe.conf

lion1810
05-11-2007, 11:07
ahhhhhhhhhhh capisco.

sacarde ti chiedo una precisazione :D :D :D

se analizziamo

sb io=0x220 irq=5 dma=1 dma16=5

sb dovrebbe (dico DOVREBBE) essere il modulo per la sound blaster nonricordocosa
e solo
io=0x220 irq=5 dma=1 dma16=5

sono i paramentri per il modulo sb

sacarde
05-11-2007, 11:26
si

mi sa di si

lion1810
05-11-2007, 11:31
... e comunque devo mettere tutto (modulo+parametro)

sb io=0x220 irq=5 dma=1 dma16=5

in

modprobe.conf

non solo
io=0x220 irq=5 dma=1 dma16=5

... immagino che se mettessi solo io=0x220 irq=5 dma=1 dma16=5 non pesno che il sistema riesca a capire che sono i parametri di sb ... :master: :master: :master:

sacarde
05-11-2007, 11:46
dovrebbe essere:


options nomemodulo opzioni


fai un : man modprobe.conf

lion1810
05-11-2007, 12:12
devo utilizzare install?
cioe'

install sb io=0x220 irq=5 dma=1 dma16=5

:fagiano:

Loading