PDA

Visualizza la versione completa : guida compiz+aiglx


bovy
05-11-2007, 19:44
qualcuno mi può consigliare una guida seria o darmi le indicazioni per rimuovere compiz e compiz manager in modo completo da ubuntu 7.10 per poi ripartire da capo e facendolo funzionare senza usare le xgl ma le aiglx! grazie

ho usa scheda video ati radeon 9550 da 256Mb, chiunque abbia dei consigli da darmi per fare andare il tutto, me li dia grazie!

premetto che non sono molto esperto e che mi sa che ho fatto un po di casino, per quello voglio toglierlo e poi rimetterlo. ero riuscito a farlo andare ( con xgl) però dopo ho aggiornato il sistema e non andava più e mi hanno consigliato di utilizzare aiglx!

mmbarabba
06-11-2007, 12:47
Avevo fatto una guida per installare i driver ATI 8.42 (http://www.mmbarabba.it/modules.php?name=News&file=article&sid=145)
e usare AIGLX al posto di XGL

se riesci a installare i driver e gli output sono tutti a posto
allora procedi con l'installazione di compiz-fusion
che dovrebbe essere nelle repo universe ufficiali della gutsy

se sei passato dalla 7.04 alla 7.10
prima di aggiornare compiz devi rimuovere tutto quello che avevi installato prima (di compiz)
che doveva essere delle repo di travino

per attivare compiz da gnome lancia il comando

compiz --replace
da KDE

compiz

bovy
06-11-2007, 15:20
ok..guida seguita alla lettere e tutto è andato bene. quado però ho dato il comando compiz --replace mi ha dato questo errore:
Checking for Xgl: not present.
Blacklisted PCIID '1002:4153' found
aborting and using fallback: /usr/bin/metacity

allora sono andato in effetti visivi per impostare custom (visto che era su none) e mi da il messaggio di errore: Desktop effects could not be enabled

cosa faccio adesso?

bovy
06-11-2007, 15:29
ah una cosa: dopo aver installatio i driver ati e aver abilitato aiglx e disabilitato xgl, in driver con restrizioni come deve essere l'impostazione della scheda video?

adesso da me è così, ditemi se va bene

http://img64.imageshack.us/img64/8682/screenshotfy6.th.png (http://img64.imageshack.us/my.php?image=screenshotfy6.png)


questo è il messaggio di errore che vi dicevo prima:

bovy@bovy-desktop:~$ compiz –replace -v &
[1] 5905
bovy@bovy-desktop:~$ Checking for Xgl: not present.
Blacklisted PCIID '1002:4153' found
aborting and using fallback: /usr/bin/metacity
metacity: Unknown option -v

mmbarabba
06-11-2007, 15:33
adesso da me è così, ditemi se va bene

secondo me va bene così

hai fatto ?

sudo gedit /usr/bin/compiz e aggiungiamo fglrx così : # Driver whitelist WHITELIST=”nvidia intel ati radeon i810 fglrx“

bovy
06-11-2007, 15:38
si fatto...ho trovato questo su google: http://www.intilinux.com/howto/409/ubuntu-gutsy-710-compiz-e-schede-video-ati/

qui dice verso la fine, che quando compare quel messaggio, bisogna aggiungere una stringa e un file. io l'ho aggiunta e digitando compiz --replace da terminale, mi dice:




bovy@bovy-desktop:~$ compiz –replace -v &
[1] 6212
bovy@bovy-desktop:~$ Checking for Xgl: not present.
Blacklisted PCIID '1002:4153' found
SKIP_CHECKS is yes, so continuing despite problems.
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1024x768) to maximum 3D texture size (2048): Passed.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting gtk-window-decorator
/usr/bin/compiz.real (core) - Warn: Unknown option '-v'

/usr/bin/compiz.real (core) - Error: Couldn't load plugin '–replace'

mmbarabba
06-11-2007, 15:47
il comando è

compiz --replace

con lacune schede nel file xorg.conf
bisogna mettere

Section “Extensions”
Option “Composite” “True”
EndSection

Section “ServerFlags”
Option “AIGLX” “True”
EndSection

in altre non ci vogliono e in altre ancora funziona solo con AIGLX true

fai un paio di prove

il fatto che ti dica

bovy@bovy-desktop:~$ Checking for Xgl: not present.
vuol dire che cerca XGL che tu hai rimosso

secondo me non hai eseguito tutto bene

prova a ricontrollare tutto da capo

bovy
06-11-2007, 16:15
rifatto tutto senza errori.
'unica cosa che fa rimanere perplesso è quello del file xorg.conf

ti faccio vedere il perchè: ( ecco il file originale) ti evidenzio in rosso quello che mi fa rimanere perplesso perchè non capisco cosa devo fare( con le cose in rosso) nel mio caso seguendo la tua guida.
se vuoi guarda se trovi qualcosa di strano nel file



# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
Option "AIGLX" "true"
# Uncomment if you have a wacom tablet
EndSection

Section "Files"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "int10"
Load "vbe"
Load "glx"
Load "GLcore"
Load "dri"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "Relisys 772"
ModelName "Custom 1"
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "640x480@72" 31.5 640 664 704 832 480 489 491 520 -hsync -vsync
ModeLine "640x480@75" 31.5 640 656 720 840 480 481 484 500 -hsync -vsync
ModeLine "640x480@85" 36.0 640 696 752 832 480 481 484 509 -hsync -vsync
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
ModeLine "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
ModeLine "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "832x624@75" 57.3 832 864 928 1152 624 625 628 667 -hsync -vsync
ModeLine "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
ModeLine "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
ModeLine "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
ModeLine "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync +vsync interlace
ModeLine "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
ModeLine "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
ModeLine "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
ModeLine "1400x1050@60" 122.6 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
EndSection

Section "Monitor"
#
Identifier "monitor1"
Gamma 1
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "ATI Technologies Inc RV350 AS [Radeon 9550]"
Driver "fglrx"
VendorName "ATI"
BoardName "ATI Radeon"
Option "MergedFB" "off"
BusID "PCI:1:0:0"
EndSection

Section "Device"
#
Identifier "device1"
Driver "fglrx"
VendorName "ATI"
BoardName "ATI Radeon"
Option "MergedFB" "off"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc RV350 AS [Radeon 9550]"
Monitor "Relisys 772"
DefaultDepth 24
SubSection "Display"
Virtual 1400 1050
Depth 24
Modes "1024x768@85" "1024x768@75" "832x624@75" "1024x768@70" "800x600@60" "1024x768@60" "800x600@85" "1024x768@43" "800x600@75" "1152x864@75" "800x600@72" "1280x960@60" "800x600@56" "1280x1024@60" "640x480@85" "1400x1050@60" "640x480@75" "640x480@72" "640x480@60"
EndSubSection
EndSection

Section "Screen"
#
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

#Section "Extensions"
# Option "Composite" "0"
#EndSection

bovy
06-11-2007, 16:24
piccolo dettaglio frose insignificante: ecco come appare nel menù preferenze il compiz manager:
http://img103.imageshack.us/img103/9950/screenshot21lh4.th.png (http://img103.imageshack.us/my.php?image=screenshot21lh4.png)

P.S.tra l'altro non riesco a lanciarlo
quando imposto custom negli effetti visivi e poi lo chiudo, subito dopo lo riapro e è impostato su extra. se è impostato su qualcosa di diverso da none, mi scompare ( nelle finestre) la barra dove di solito c'è la x per chiudere e il quadrato per massimizzare o minimizzare la finestra

mmbarabba
06-11-2007, 17:21
ubuntu wiki compiz-fusion (http://wiki.ubuntu-it.org/CompositeManager/CompizFusion?highlight=%28compiz%29)

hai dato un'occhio al wiki ?


Abilitazione
Per abilitare gli effetti visibi è sufficiente fare cli su Sistema -> Preferenze -> Aspetto e nella pagina «Effetti visivi» selezionare una voce fra «Normali», «Extra» e «Personalizzato».

il tuo file xorg.conf mi pare un pò pasticciato
richiami in device fglrx ben 3 volte
a me pare ne basti una

questo è il mio sulla 9600


Section "Files"
FontPath "/usr/share/fonts/X11/misc"
# FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "ati"
Driver "fglrx"
BusID "PCI:1:0:0"
VideoRam 256000
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 30-81
VertRefresh 56-76
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ati"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection

:unz:

Loading