PDA

Visualizza la versione completa : swap inattiva..


dariohq
18-11-2007, 20:05
salve a tutti smanettando su Ubuntu 7.10 mi sono accorto di una cosa strana..la partizione di swap non attiva
digitando "free" da terminale compare

total used free shared buffers cached
Mem: 515840 509756 6084 0 1660 112580
-/+ buffers/cache: 395516 120324
Swap: 0 0 0

il problema viene risolto digitando "sudo swapon /dev/hda5"

infatti ridigitando "free"

total used free shared buffers cached
Mem: 515840 507368 8472 0 844 108624
-/+ buffers/cache: 397900 117940
Swap: 1510068 940 1509128

lo swap viene attivato.

Il problema che a ogni riavvio del PC lo swap si disattiva.

C' un modo per attivarla automaticamente senza ridigitare sempre "sudo swapon /dev/hda5" ??

Se d'aiuto edito fstab


# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda6
UUID=51141455-8e12-4b00-9803-1c5c37e9cf4c / ext3 defaults,errors=remount-ro,noatime,data=writeback 0 1
# /dev/hda1
UUID=f1a03a05-8bab-4f87-9ac0-834c7573ac1e /home ext3 defaults 0 0
# /dev/hdb1
UUID=20e1b6ba-281d-471f-bb8a-80559083a872 /media/hdb1 ext3 defaults 0 0
# /dev/hda5
UUID=a6c9dcb4-1138-47cf-9ef7-2af6cfb0b80b swap sw 0 0
# /dev/hdb5
UUID=b039a976-fa38-4f04-a7fb-f6956dcb9aff none
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/hdc /media/cdrom1 udf,iso9660 user,noauto,exec 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec 0 0
tmpfs /dev/shm tmpfs defaults,ro 0 0

andy caps
18-11-2007, 21:07
probabilmente la setta da se off

comunque sembra mancare un " none " in fstab


metti

# /dev/hda5
UUID=a6c9dcb4-1138-47cf-9ef7-2af6cfb0b80b none swap sw 0 0

dariohq
18-11-2007, 21:52
niente da fare.

provato ad aggiungere "none" e ho riavviato
# /dev/hda5
UUID=a6c9dcb4-1138-47cf-9ef7-2af6cfb0b80b none swap sw 0 0

devo sempre attivarla manualmente

andy caps
18-11-2007, 22:02
prova a mettere il pc sotto stress per vedere se l'attiva successivamente da se

francofait
18-11-2007, 22:10
togli quel puttanaio di indirizzi uuid da fstab e ripristina l' indirizzamento classico /dev/hdxx su tutte le partiz , inclusa swap e vedrai che il problema si chiude e non si ripresenta pi.

dariohq
18-11-2007, 22:20
su monitor di sistema adesso l'uso della memoria 82,4 % (sta usando 415mb su 503 disponibili)
lo swap resta sempre 0 di 0

se invece digito a terminale "sudo swapon /dev/hda5" (la partizione di swap) questa si attiva.

Non c' modo di attivarla automaticamente? su Ubuntu sono andato su Sistema ---> Preferenze --sessioni e ho aggiunto il comando (sudo swapon /dev/hda5) nella sezione programmi di avvio ma senza nessun risultato.

Approffitto per un'altra domanda..girando per internet ho trovato alcune informazioni su come ottimizzare lo swap...in pratica bisogna editare il file /etc/sysctl.conf e nella voce "vm.swappiness=" bisogna mettere un numero da 0 a 100....purtroppo non ho capito una cosa..
con 512 mb di ram il valore meglio tenerlo alto o basso? E' normale che con tanti servizi inutili disattivati qualsiasi windows manager (Xfce Gnome e persino amiwm) appena fatto il login mangi 40 -50 % della Ram?

dariohq
18-11-2007, 22:21
Originariamente inviato da francofait
togli quel puttanaio di indirizzi uuid da fstab e ripristina l' indirizzamento classico /dev/hdxx su tutte le partiz , inclusa swap e vedrai che il problema si chiude e non si ripresenta pi.

Ok adesso provo e vi paccio sapere

Grazie per le risposte!!!

andy caps
18-11-2007, 22:34
guarda che l a partizione sia formattata correttamente swap

mkswap /dev/hda5


a male estremi da root crea un file a caso swappp

mettici il comando

sudo swapon /dev/hda5
e dopo averlo reso eseguibile

update-rc.d swappp default

lo dovrebbe avviare ad init 3

francofait
18-11-2007, 22:36
Il gestore della memoria fa ricorso a swap quando non ha pi ram libera da poter utilizzare come cache disk , per cui perfettamente normale.
Per il kernel di linux quando un processo terminato lo spazio occupato da quel processo assunto come libero e disponibile per altri processi che ne facciano richiesta.

dariohq
18-11-2007, 22:38
Credo di aver capito male :confused:

ho tolto gli indirizzi uuid e riavviato...alla schermata di login se digito il mio utente e password mi dice che la mia home personale non esiste pi o quacosa del genere (che poi non vero perch riesco a vedere la mia cartella e file tramite la distro Live)
il file fstab adesso cos

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda6
/ ext3 defaults,errors=remount-ro,noatime,data=writeback 0 1
# /dev/hda1
/home ext3 defaults 0 0
# /dev/hdb1
/media/hdb1 ext3 defaults 0 0
# /dev/hda5 none swap sw 0 0
# /dev/hdb5
none
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/hdc /media/cdrom1 udf,iso9660 user,noauto,exec 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec 0 0
tmpfs /dev/shm tmpfs defaults,ro 0 0

ho fatto sicuramente qualche cavolata ma nn so cosa
alla peggio ripristino quello vecchio :confused:

Loading