PDA

Visualizza la versione completa : [USB su UBUNTU] automount su penna usb non + funzionante


ZeroOne
24-11-2007, 04:42
salve
ho letto un po di topic sia qui, sia su altri forum sia su google ma niente di fatto
premettendo che non è colpa di gparted come successo ad alcuni xchè nel mio caso NON E' PRESENTE il file usr/share/hal/fdi/policy/gparted-disable-automount.fdi
da un po di tempo quando collego a sistema già avviato una chiavetta usb fat32 non fa l'automount
riavviando con la chiavetta inserita invece tutto ok ma espellendola e reinserendola non salta fuori nulla
con il mount manuale tutto ok invece

le prove che ho fatto sono le seguenti:

lanciando il comando
gnome-mount -vbd /dev/sdb1
mi appare

gnome-mount 0.5
libhal-storage.c 1401 : INFO: called LIBHAL_FREE_DBUS_ERROR but dbusError was not set.

** (gnome-mount:6868): WARNING **: Il device "/dev/sdb1" fornito non è né un volume, né un'unità.

altra cosa strana è che non ho /etc/init.d/hal
e hal non lo trovo da nessuna parte

ho editato etc/hal/fdi/policy/preferences.fdi
inserendo <merge key=”volume.ignore” type=”bool”>false</merge>
ma niente da fare

ho dato infine il comando
dmesg | tail -f /var/log/messages
per vedere in tempo reale cosa succede quando collego la penna
l'output è il seguente

Nov 23 20:08:11 quincy kernel: [ 486.796000] usb 5-5: new high speed USB device using ehci_hcd and address 5
Nov 23 20:08:11 quincy kernel: [ 486.932000] usb 5-5: configuration #1 chosen from 1 choice
Nov 23 20:08:12 quincy kernel: [ 486.932000] scsi5 : SCSI emulation for USB Mass Storage devices
Nov 23 20:08:16 quincy kernel: [ 491.932000] scsi 5:0:0:0: Direct-Access Generic STORAGE DEVICE 1.04 PQ: 0 ANSI: 0
Nov 23 20:08:17 quincy kernel: [ 492.188000] SCSI device sdb: 512000 512-byte hdwr sectors (262 MB)
Nov 23 20:08:17 quincy kernel: [ 492.312000] usb 5-5: reset high speed USB device using ehci_hcd and address 5
Nov 23 20:08:17 quincy kernel: [ 492.828000] usb 5-5: reset high speed USB device using ehci_hcd and address 5
Nov 23 20:08:18 quincy kernel: [ 493.344000] usb 5-5: reset high speed USB device using ehci_hcd and address 5
Nov 23 20:08:18 quincy kernel: [ 493.868000] usb 5-5: reset high speed USB device using ehci_hcd and address 5
Nov 23 20:08:19 quincy kernel: [ 494.384000] usb 5-5: reset high speed USB device using ehci_hcd and address 5
Nov 23 20:08:19 quincy kernel: [ 494.900000] usb 5-5: reset high speed USB device using ehci_hcd and address 5
Nov 23 20:08:20 quincy kernel: [ 495.036000] sdb: Write Protect is off
Nov 23 20:08:20 quincy kernel: [ 495.296000] SCSI device sdb: 512000 512-byte hdwr sectors (262 MB)
Nov 23 20:08:20 quincy kernel: [ 495.420000] usb 5-5: reset high speed USB device using ehci_hcd and address 5
Nov 23 20:08:20 quincy kernel: [ 495.936000] usb 5-5: reset high speed USB device using ehci_hcd and address 5
Nov 23 20:08:21 quincy kernel: [ 496.448000] usb 5-5: reset high speed USB device using ehci_hcd and address 5
Nov 23 20:08:21 quincy kernel: [ 496.972000] usb 5-5: reset high speed USB device using ehci_hcd and address 5
Nov 23 20:08:22 quincy kernel: [ 497.488000] usb 5-5: reset high speed USB device using ehci_hcd and address 5
Nov 23 20:08:23 quincy kernel: [ 498.004000] usb 5-5: reset high speed USB device using ehci_hcd and address 5
Nov 23 20:08:23 quincy kernel: [ 498.140000] sdb: Write Protect is off
Nov 23 20:08:23 quincy kernel: [ 498.144000] sdb: sdb1
Nov 23 20:08:23 quincy kernel: [ 498.400000] sd 5:0:0:0: Attached scsi removable disk sdb
Nov 23 20:08:23 quincy kernel: [ 498.400000] sd 5:0:0:0: Attached scsi generic sg1 type 0

e la cosa finisce lì

prima avevo gparted installato
lui mi riconosceva la partizione ma mi diceva filesystem non conosciuto, controllare di avere il plugin installato
o una cosa simile cmq

qualcuno ha alternative da provare?
grazie
ciao

Loading