PDA

Visualizza la versione completa : pacchetto locales su debian sid


jimbojack
24-11-2007, 20:13
ormai da qualche settimana aggiornando debian sid ottengo sempre il medesimo errore sul pacchetto locales:


I seguenti pacchetti hanno dipendenze non soddisfatte:
locales: Dipende: glibc-2.7-1 che un pacchetto virtuale.
Resolving dependencies...
Le seguenti azioni permetteranno di soddisfare queste dipendenze:

Mantenere i seguenti pacchetti alla versione attuale:
locales [2.6.1-6 (now)]

Il punteggio 120

Accettare questa soluzione? [Y/n/q/?]

come posso risolvere?

francofait
24-11-2007, 20:34
da console su root
apt-get -f install
apt-get update
apt-get -f dist-upgrade

jimbojack
24-11-2007, 20:45
Originariamente inviato da francofait
da console su root
apt-get -f install
apt-get update
apt-get -f dist-upgrade

alla fine ottengo:


apt-get -f dist-upgrade
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso
Reading state information... Fatto
Calcolo dell'aggiornamento in corso... Fatto
I seguenti pacchetti sono stati mantenuti alla versione attuale:
locales
0 aggiornati, 0 installati, 0 da rimuovere e 1 non aggiornati.

andy caps
24-11-2007, 21:35
momentaneamente per locales si deve usare il pacchetto locales-all http://packages.debian.org/sid/locales-all

probabilmente quando aggiorneranno glib alla versione 2.7 tornera' tutto normale

la 2.7 disponibile solo per architetture
amd64
ia64

andy caps
25-11-2007, 00:56
comunque con l'aggiornamento odierno hanno messo libc6-dev (2.7-1)

ed installa anche locales

jimbojack
25-11-2007, 11:03
aggiornato in questo momento.

grazie!! :ciauz:

Loading