PDA

Visualizza la versione completa : java..come installarlo??


Etidr3k
09-12-2007, 16:55
Salve ragazzi...
Mi servirebbe una mano!
Allora, io ho Linux Ubuntu 7.10 e dovrei installare il pacchetto java!
Per ho un problema, io quando vado a digitare nel terminale il comando:
Codice:
sudo apt-get install sun-java5-jre

mi da un errore di questo tipo:


lorenzo@lorenzo-desktop:~$ sudo apt-get install sun-java5-jre
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
lorenzo@lorenzo-desktop:~$

e non tutto, inoltre mi da errore "'dpkg --configure -a'" anche quando cerco di installare gli ultimi aggiornamenti:


E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.


Cosa vuol dire tutto questo?
Come potrei risolverlo?..aspetto vostra risposta, grazie in anticipo :ciauz:

francofait
09-12-2007, 17:20
Originariamente inviato da Etidr3k
Salve ragazzi...
Mi servirebbe una mano!
Allora, io ho Linux Ubuntu 7.10 e dovrei installare il pacchetto java!
Per ho un problema, io quando vado a digitare nel terminale il comando:
Codice:
sudo apt-get install sun-java5-jre

mi da un errore di questo tipo:


lorenzo@lorenzo-desktop:~$ sudo apt-get install sun-java5-jre
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
lorenzo@lorenzo-desktop:~$

e non tutto, inoltre mi da errore "'dpkg --configure -a'" anche quando cerco di installare gli ultimi aggiornamenti:


E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.


Cosa vuol dire tutto questo?
Come potrei risolverlo?..aspetto vostra risposta, grazie in anticipo :ciauz:

2) per caricare ed installare gli aggiornamenti da console , prima di tutto va sempre e comunque eseguito prima l' update :

apt-get update

seguito da un semplicissimo -f upgrade

apt-get -f upgrade

dpkg con l' upgrade e l' install da rete ce st quanto cavoli a merenda.

1) per quanto riguarda sun java , i pacchetti nelle repositri si scaricano utilizzando la sintassi usata sulle repositry.
Per cercare ed installare pacchetti in Ubuntu ,come in tutte le derivate debian ,synaptic c' e serve proprio per evitare ricerche al buio della console , usalo e vedrai che sun java lo trovi e lo installi subito , completo di tutti i suoi pacchetti.

Etidr3k
11-12-2007, 19:38
ecco..ho provato a seguire il tuo consiglio;
ho digitato sul terminale:

apt-get update

oppure

apt-get -f upgrade

ma mi da questo genere di errore..e io non capisco cosa voglia dire



lorenzo@lorenzo-desktop:~$ apt-get update
E: Impossibile aprire il file di lock /var/lib/apt/lists/lock - open (13 Permesso negato)
E: Impossibile creare un lock sulla directory di list
lorenzo@lorenzo-desktop:~$ apt-get -f upgrade
E: Impossibile aprire il file di lock /var/lib/dpkg/lock - open (13 Permesso negato)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
lorenzo@lorenzo-desktop:~$


cosa dovrei fare?? :dh:

francofait
11-12-2007, 20:24
hai gi una sessione apt attiva devi chiuderla.
Per default il SO ti pone l' adept manager attivo in funzione , con la sua icona ben visibile nel pannello . Chiudilo , anche adept come synaptic e tutti i gestori di pacchetti per X una gui per apt e di conseguenza con la sua attivazione ne apre inevitabilmente una sessione , inpedendo in tal modo altre operazioni apt sia in console che con altre gui.

Etidr3k
11-12-2007, 21:36
non capisco..come devo fare per chiuderla? e poi??
non potresti fami una lista di codici con i vari passaggi?

psykopear
11-12-2007, 21:48
Originariamente inviato da Etidr3k
non capisco..come devo fare per chiuderla? e poi??
non potresti fami una lista di codici con i vari passaggi?

Franco, non hai notato che non root?Metti sudo prima dei comandi

sudo apt-get update

Etidr3k
12-12-2007, 18:15
ok, fino a qui ero arrivato pure io!
per successivamente mi apare un errore ke mi vieta di portare a termine l'installazione di java..mi dice di digitare dpkg... io lo digito ma non ho i requisiti necessari..cio non mi vede come "superuser" anche se realmente sono l'unico utente di questo pc..e non vedo come potuto sorgere questo problema..
Qualcuno di voi sa darmi una spiegazione? :confused:

francofait
12-12-2007, 18:26
non esiste utente unico in lunux , anche se in ubuntu l' accesso diretto a root inibito rendendolo shadow root comunque presente . Solo root padrone sassoluto del SO , senza acquisirne prima i privilegi via sudo non puoi effettuare modifiche di alcun genere al SO .
I privilegi admin acquisiti non hanno carattere permanennte , valgono unicamente per la sessione sudo che li ha richiesti.

Etidr3k
12-12-2007, 18:36
e come devo fare per mettere tutto normale??
non capisco pi nulla..non riesco ad aggiornare..ad installare..non riesco a fare nulla!!! :dh: :dh: :dh: :dh:
ogni volta, inoltre, mi da un errore ke non capisco..:

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

francofait
12-12-2007, 18:44
te lo sta dicendo da se cosa devi fare per ripristinare il corretto funzionamento di apt:
da console
sudo dpkg --configure -a
O meglio usa le maniere forti:

sudo dpkg --force-all --configure -a

e lo fai seguire con un:

sudo apt-get -f install # (senza niente altro)

Loading