PDA

Visualizza la versione completa : [PYTHON] Librerie grafiche supportate per Windows/Linux


dail
15-12-2007, 12:42
Ciao a tutti,
Secondo voi (graficamente parlando) quali sono li migliori librerie grafiche utilizzabili tramite python?
A mio parere le PyQt sembrano ottime...che ne pensate? Sono ben supportate sia su linux che su windows? Inoltre è possibile utilizzare il qt designer per lavorare con le finestre tramite python?


grazie a tutti

pallinopinco
15-12-2007, 12:48
Io preferisco le wxPython+wxGlade, ma anche le pyQT sono ben fatte. Provale entrambe e vedi quale ti sembra più adatta per il tuo caso.

dail
15-12-2007, 12:57
ti ringrazio per la risposta velocissima...


una cosa però riguardo le qt.....ma c'è abbastanza documentazione per utilizzarle?
ho visto anche le gtk li ce nè moltissima....ma oltre alle gtk bisogna installare pango e cairo...vorrei diciamo un pacchetto unico che comprenda tutto...come credo le qt...sbaglio?


grazie mille

pallinopinco
15-12-2007, 14:43
Oltre alla documentazione ufficiale delle QT puoi fare riferimento a quella pubblicata sul sito del progetto PyQT (http://www.riverbankcomputing.co.uk/pyqt/).



Binary Packages

The binary installer for Windows contains everything needed for PyQt development except for Python itself. :

PyQt
Qt (with database support for SQLite3 and ODBC)
Qt Designer
Qt Linguist
Qt Assistant
pyuic4
pylupdate4
lrelease
pyrcc4
QScintilla
PyQwt
Qwt
eric IDE

dail
15-12-2007, 23:48
Originariamente inviato da pallinopinco
Oltre alla documentazione ufficiale delle QT puoi fare riferimento a quella pubblicata sul sito del progetto PyQT (http://www.riverbankcomputing.co.uk/pyqt/).

cioè scusami non ho capito...devo installarmi anche tutta quella robba li??? :dottò:

menphisx
16-12-2007, 00:44
PyQt (come le qt) non richiede praticamente dipendenze, la maggior parte dei pacchetti che ti ha elencato pallonpinco sono per lo sviluppatore.

:ciauz:

dail
16-12-2007, 03:32
Originariamente inviato da menphisx
PyQt (come le qt) non richiede praticamente dipendenze, la maggior parte dei pacchetti che ti ha elencato pallonpinco sono per lo sviluppatore.

:ciauz:

per lo sviluppatore?? ma io devo lavorare con python+qt.....cioè non voglio far girare applicazioni solamente che utilizzano python + qt ma vorrei provare a realizzarle anche io....quindi che pacchetti servono per programmare in python usando le qt?

grazie

menphisx
16-12-2007, 04:03
avro capito male :fagiano:
vanno bene quelli che ha elencato pallinopinco

dail
16-12-2007, 11:45
Originariamente inviato da menphisx
avro capito male :fagiano:
vanno bene quelli che ha elencato pallinopinco

eh ma e poi per l'utente che utilizzerà l'applicazione??? gli devo far installare tutti quei pacchetti?

grazie mille

dail
16-12-2007, 11:49
però non capisco nella guida http://www.riverbankcomputing.com/Docs/PyQt4/pyqt4ref.html

non elenca tutti quei pacchetti...ma indica l'installazione solo delle pyqt e stop

Loading