PDA

Visualizza la versione completa : riconfigurare grub


chemako
08-01-2008, 23:35
ciao cari, ho questo in menu.lst

title Ubuntu 7.10, memtest86+
root (hd1,0)
kernel /boot/memtest86+.bin
quiet

devo dire a grub questo

mem=4096M

altrimenti non mi funzica paralles, su lilo me la cavavo, su grub no, son due ore che cerco e non ho risolto, come azzo si fa? :stordita:

Sachertorte
08-01-2008, 23:43
credo che si debba semplicemente aggiungere alla riga del kernel
http://www.gnu.org/software/grub/manual/grub.html

comunque quello che hai postato è l'avvio del memtest86, che ti frega di lanciare il memtest di Linux da parallels? MacOS non ne ha già uno suo da qualche parte?

marco@linuxbox
08-01-2008, 23:50
hai provato

mem=4G

?

francofait
08-01-2008, 23:56
title Ubuntu 7.10, memtest86+
root (hd1,0)
kernel /boot/memtest86+.bin
quiet
uppermem kbytes

chemako
09-01-2008, 00:00
sono su ubuntu, non devo impostare mem=4096M su parallels, è che parallels non mi fa partire l'installazione di xp e mi dice di aggiungere al boot loader l'opzione mem=4096
quindi dovrei nella linea del kernel aggiungere mem=4096M
ma grub non è come lilo che va aggiornato dopo una modifica vero? se mi ricordo bene non importa
mem=4G non credo viene indicato espressamente 4096M
boh io provo, male male riparto col recovery :stordita:

chemako
09-01-2008, 00:01
oè, grazie franco :D

chemako
09-01-2008, 00:10
nemmeno così funziona, franco :cry:

posto l'esatto errore che mi da parallels



Parallels Workstation experience problem when trying to allocate physical memory in PAE mode. The current version of Parallels Workstation supports up to 4 GB of physical memory. To fix the problem you have to change the auto detected memory size to 4096MB. Add to your boot loader the following option "mem=4096M".

chemako
09-01-2008, 00:16
ok risolto, bastava aggiungere mem=4096M alla riga del kernel come detto da Sachertorte, lo avevo già fatto ma non partiva più ubuntu, ero dovuto andare col recovery per risistemare, si vede avevo digitato male un numero o una lettera
se mi funzica capture nx come dio comanda con parallels, posso tornare a linux al 100% :sbav:

Loading