PDA

Visualizza la versione completa : [Mandriva] kernel 2.6.17 su ThinkPad T41


Akiro
12-01-2008, 17:08
ciao a tutti,
sto "smandruppando" un po il portatile e vorrei un parere, qualche consiglio, delle dritte sull'attuale configurazione. Tenete conto che le cose da fare sono molte per abilitare tutte le funzioni, ma magari c'Ŕ qualche utente che ha un ThinkPad simile...

qui (http://www-307.ibm.com/pc/support/site.wss/MIGR-58183.html) ci sono le specifiche tecniche del portatile dal sito Lenovo.
Ecco il mio .config (http://w13.easy-share.com/14704221.html) ed ecco il dmesg (http://w13.easy-share.com/14704231.html).

Ogni consiglio Ŕ ben accetto, grazie 8 )

Akiro
14-01-2008, 10:33
Nessuno con un Thinkpad simile?

claudiocrack
14-01-2008, 10:37
Io ho un thinkpad r51 ci ho fatto girare mandriva senza problemi ha rilevato TUTTO
stessa cosa slackware , debian , gentoo , solaris...
Ho preso apposta un thinkpad perche so che l'hardware Ŕ supportato alla grande...
ps..anche il lettore pcmcia funziona perfettamente...
e i tasti di funzione volume ecc ecc funzionano pure quelli senza far nulla...
l'unica che pero al momento che uso i tasti nn mi fa vedere il liello del volume a schermo Ŕ slackware per le altre segnala pure il livello a display
inoltre il trackpoint Ŕ riconosciuto e funzionante...ho trovato problemi solo una volta con una vecchia slax nn ricordo il kernel ma era intorno al 2005 quando l' ho installata

:ciauz:

mykol
14-01-2008, 10:38
dal kernel immagino che vuoi metterci la 2007 spring. PerchŔ non la 2008 ?

Con un kernel aggiornato hai probabilitÓ che riconosca pi¨ hardware.

Akiro
14-01-2008, 11:02
Originariamente inviato da claudiocrack
l'unica che pero al momento che uso i tasti nn mi fa vedere il liello del volume a schermo Ŕ slackware per le altre segnala pure il livello a display


per l'OSD ed il riconoscimento dei relativi tasti io uso tpb (http://www.thinkwiki.org/wiki/Tpb)

Akiro
14-01-2008, 11:04
Originariamente inviato da mykol
dal kernel immagino che vuoi metterci la 2007 spring. PerchŔ non la 2008 ?

Con un kernel aggiornato hai probabilitÓ che riconosca pi¨ hardware.

ho giÓ installato la 2007 Spring, il kernel ho preso l'ultimo source presente nei repository per comoditÓ 8o)
Per passare alla 2008 mi sa che c'Ŕ tempo 8D

Akiro
15-01-2008, 12:42
mi sono accorto di un piccolo errore...

il .config che ho inserito Ŕ il file originale del kernel 2.6.17-16mdv e non la mia versione customizzata!!!


ho seguito questa guida (http://www.mandrakeitalia.org/modules/wfsection/article.php?articleid=215) ma noto che sotto /boot .config punta alla vecchia versione:


lrwxrwxrwx 1 root root 19 gen 12 17:26 config -> config-2.6.17-16mdv
-rw-r--r-- 1 root root 77460 set 26 22:19 config-2.6.17-16mdv

Ŕ un problema? si pu˛ recuperare il .config che ho compilato?
:fagiano: :fagiano:

Akiro
15-01-2008, 14:42
trovato il problema, sono io che sono pirla... 8 )))

Ecco il file .config che sto usando ora .config-2.6.17-16mdvcustom (http://w15.easy-share.com/14961411.html).

Ogni consiglio Ŕ ancora ben accetto, grazie 8 )

Akiro
07-08-2009, 13:50
Scusate, ho visto che Ŕ uscito un pacchetto dkms-thinkpad (http://rpm.pbone.net/index.php3/stat/4/idpl/12244554/com/dkms-thinkpad-6.0-2mdv2009.1.noarch.rpm.html):

Description : This package contains a DKMS-ready module adding kernel support for older Thinkpad laptops.

Ma come faccio a sapere se il mio Ŕ abbastanza vecchio???
:fagiano:

mykol
08-08-2009, 10:48
con il pacchetto dkms-thinkpad non c'Ú un "read me" ?

Comunque prova ad installarlo .... con mandriva mettrlo e toglierlo si fa in un attimo in automatico ..


Oppure mettici la 2009.1 che Ŕ tutt'altra cosa,

Loading