PDA

Visualizza la versione completa : [Mandriva 2008.0]Problema con OpenGL e scheda video


Tux_viola
28-01-2008, 23:43
Salve gente........ho installato Openarena come rpm sul mio portatile. Ho una scheda video Intel Mobile GM965/GL960 Integrated Graphics Controller. Uso il driver ‎che ha modulo Card:Intel 810 and later
Quando lancio il comando sia da root che no: /usr/games/openarena

Questo l'errore che mi restituisce:

ioQ3 1.33+oa linux-i386 Jul 15 2007
----- FS_Startup -----
Current search path:
/home/guido/.openarena/baseoa
/usr/lib/games/openarena/baseoa/pak7-patch.pk3 (76 files)
/usr/lib/games/openarena/baseoa/pak6-misc.pk3 (191 files)
/usr/lib/games/openarena/baseoa/pak5-TA.pk3 (11 files)
/usr/lib/games/openarena/baseoa/pak4-textures.pk3 (1496 files)
/usr/lib/games/openarena/baseoa/pak3-music.pk3 (9 files)
/usr/lib/games/openarena/baseoa/pak2-players.pk3 (620 files)
/usr/lib/games/openarena/baseoa/pak2-players-mature.pk3 (171 files)
/usr/lib/games/openarena/baseoa/pak1-maps.pk3 (73 files)
/usr/lib/games/openarena/baseoa/pak0.pk3 (926 files)
/usr/lib/games/openarena/baseoa

----------------------
3573 files in pk3 files
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
Couldn't read q3history.
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----

------- Input Initialization -------
Joystick is not active.
------------------------------------
...loading libGL.so.1:
Calling SDL_Init(SDL_INIT_VIDEO)...
SDL_Init(SDL_INIT_VIDEO) passed.
Initializing OpenGL display
...setting mode 3: 640 480
libGL error: drmMap of framebuffer failed (Invalid argument)
libGL error: reverting to (slow) indirect rendering
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: Mesa GLX Indirect


************************************************** *********
You are using software Mesa (no hardware acceleration)!
Driver DLL used: libGL.so.1
If this is intentional, add
"+set r_allowSoftwareGL 1"
to the command line when starting the game.
************************************************** *********
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem

Ho provato con il comando che mi dice lui aggiungendo +set r_allowSoftwareGL 1
Il risultato che il gioco cos mi si avvia ma mi "lampeggia"........come se caricasse continuamente l'immagine. Cosa mi dite? Ho controllato e il flag dell'acceleratore 3D ed attivo......
Cosa suggerite?

andy caps
29-01-2008, 00:22
glxinfo | grep rendering guarda che dice ??

controlla cosa hai in /etc/X11/xorg.conf

devi avere queste voci

Section "Module"
....
Load "glx"
Load "dri"
EndSection

....

Section "Device"
Identifier "*xxxxx"
Driver "i810"
EndSection

....

Section "dri"
Mode 0666
EndSection


guarda se hai disponibile il pacchetto

dkms-drm-experimental ed eventualmente installalo

Tux_viola
29-01-2008, 00:40
Allora..........brutte notizie.........

il comando glxinfo non esiste per la bash: commaand not found.

Poi il file xorg.conf contiene questo:

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "dri" # direct rendering
EndSection

Section "Device"
Identifier "device1"
VendorName "Intel Corporation"
BoardName "Intel 810 and later"
Driver "intel"
Option "DPMS"
Option "XaaNoOffscreenPixmaps" "1"
EndSection


La sezione "dri" non esiste.

E non ho nemmeno il pacchetto dkms-drm-experimental

Che mi dici?

andy caps
29-01-2008, 00:46
installa mesa-utils per glxinfo
e magari anche i -devel di mesa e glu

prova a farla in basso la sezione dri


Section "dri"
Mode 0666
EndSection

andy caps
29-01-2008, 00:49
dkms-drm-experimental sara nella mandriva spring 2008-1 che uscira ad aprile

io uso la cooker e li c' gia

Tux_viola
29-01-2008, 01:02
libGL error: drmMap of framebuffer failed (Invalid argument)
libGL error: reverting to (slow) indirect rendering
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

Questo il messaggio che mi da con il comando glxinfo | grep rendering

Ho aggiunto la sezione al file.

andy caps
29-01-2008, 01:21
:bh: guarda se hai installato il pacchetto

x11-driver-video-intel

guarda cosa dice

cat /var/log/Xorg.0.log | grep EE

per vedere eventuali errori

cerca glu ed installa i -devel
libmesagl1-devel libmesaglut3-devel libglui2-devel

Tux_viola
02-02-2008, 11:20
Ciao; ho risolto il problema; grazie.

Loading