PDA

Visualizza la versione completa : [WEBMIN] problemi con il backup delle email


dragone67
31-01-2008, 20:37
Ciao,

sto eseguendo un backup/restore da 2 server dedicati.

Funziona tutto, tranne il fatto che le email vengono backuppate ma non restorate (vengono create le email ma sono vuote)

Se controllo nel file zippato trovo la seguente situazione :

mail_user : pieno
mail_files : pieno
mail : vuoto
mail_aliases : pieno

qualcuno sa darmi una dritta e dirmi dove sbaglio ?

backup con : Virtualmin 3.46
restore con : Virtualmin 3.50

Grazie

dragone67
01-02-2008, 13:16
Ho approfondito il problema.

Sul vecchio server ho : sendmail

Sul nuovo ho : postfix

Ho trovato uno script per migrare : Mb2md

Qualcuno sa dirmi dove trovare un tutorial in Italiano ?

Grazie

dragone67
01-02-2008, 19:16
Chi fa da se, fa per tre.

Ho risolto.

a) ho fatto il backup di tutta la cartella /var/spool/mail del vecchio server e l'ho portata pari pari nella /tmp del nuovo server

b) sul nuovo server ho copiato lo script perl mb2md.pl

c) sul nuovo server ho installato un modulino per per le date

d) sul nuovo server ho eseguito il seguente comando :

sudo -u utentecasellaemail perl /percorso/mb2md.pl -s /percorsoemailvecchia/filenamevecchiaemail -R

ed il gioco Ŕ fatto.

Per invece riportare le email inviate da webmail, non devo fare altro che copiare pari pari il file nella cartella /home/miodominio/homes/utentecasellaemail/mail/Sent dal vecchio al nuovo server

Ciao!!

sylvaticus
01-02-2008, 23:07
grazie !

Anch'io uso webmin/virtualmin e potrÓ essermi utile !

:) :)

Loading