PDA

Visualizza la versione completa : Kubuntu 7.10 AIUTO INTERNET


cioki
03-02-2008, 16:36
:dh˛: :dh˛: :dh˛:
Salve, ho installato Kubuntu 7.10
ma non riesco a collegarmi ad internet..
Praticamente dopo aver fatto la cartella resolv.conf in /etc con KPPP sono andato a rilevare il mio modem SmartLink Soft Modem non riuscendoci.....
Quindi con la Konsole ho eseguito sudo apt-get install sl-modem-daemon caricandomi I driver del mio modem sul sistema.
Infatti in KPPP se cerco il modem interno del mio Notebook lo rileva:

ATI: SmartLink Soft Modem
ATI1: SmartLink Soft Modem, 2.9.9e-pre1 Smart Link Ltd.
ATI2: SmartLink Soft Modem, 2.9.9e-pre1 Smart Link Ltd.
ATI3: modem:1 alsa modem driver
ATI4: s00=000 s01=000 s02=043 s03=013 s04=010 s05=008 s06=002 s07=060 s08=002 s09=006 s10=007 s11=100 s12=050 s13=000 s14=001 s15=001 s16=001 s17=000 s18=000 s19=000 s20=000 s21=000 s22=000 s23=000
ATI5: Stored Profile 0:
ATI6: Stored Profile 1:
ATI7: Country: USA

A questo punto con il programma KPPP mi collego anche a una velocitÓ alta 52000, ma stranamente con nessun programma (Konqueror, Adept Manager, ecc.) non riesco ad aprire nessuna pagina, come se non sono mai stato collegato.
Vi segnalo che stranamente in basso del Desktop mi segnala l'avvenuta connessione con la relativa velocitÓ, ma a destra non mi visualizza l'icona relativa alla connessione.....

G R A Z I E ...................

andy caps
03-02-2008, 18:41
potresti avere messo un gateway ed in pratica si connette alla scheda di rete

se apri un terminale da root e digiti il comando

route -a
deve mostrari in basso

tipo

0 0 0 0

se mette 192.168.1.0 hai il gateway

altrimenti prima prova a mettere un dns del tuo provider in alto togliendo quelli esistenti

nel file /etc/resolv.conf scrivi il tuo dns

es

nameserver 212.216.112.112

cioki
04-02-2008, 08:54
:dh˛: :dh˛: :dh˛: :dh˛:
Ciao, grazie di avermi risposto
ho eseguito route -a come mi hai detto dandomi queste opzioni:
route: invalid option -- a
Usage: route [-nNvee] [-FC] [<AF>] List kernel routing tables
route [-v] [-FC] {add|del|flush} ... Modify routing table for AF.

route {-h|--help} [<AF>] Detailed usage syntax for specified AF.
route {-V|--version} Display version/author and exit.

-v, --verbose be verbose
-n, --numeric don't resolve names
-e, --extend display other/more information
-F, --fib display Forwarding Information Base (default)
-C, --cache display routing cache instead of FIB

<AF>=Use '-A <af>' or '--<af>'; default: inet
List of possible address families (which support routing):
inet (DARPA Internet) inet6 (IPv6) ax25 (AMPR AX.25)
netrom (AMPR NET/ROM) ipx (Novell IPX) ddp (Appletalk DDP)
x25 (CCITT X.25)
allora ho eseguito route -n:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
151.6.148.60 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0 ppp0

penso che hai ragione tu, in quanto mi collego alla scheda di rete...
come posso fare per risolvere il problema...

Ho anche due domande da farti.
Il S.O. Kubuntu mi dice che prima di connettermi la prima volta devo fare la cartella resolv.conf in /etc, non ho capito bene se devo fare una cartella o un file.Text con Kate----

inoltre come faccio a sapere il mio dns?

scusa ma sono ancora alle prime armi con Linux Kubuntu...........

andy caps
04-02-2008, 14:14
il comando in effetti era route -n

non devi fare la cartella resolv.conf in /etc


il file resolv.conf lo dovresti trovare in /etc/ppp o semplicemente
/etc/resolv.conf

togli la cartella resolv.conf che hai creato
che potrebbe creare problemi

per il tuo dns guarda qui http://forum.wininizio.it/index.php?showtopic=5997 o meglio cerca sul sito del tuo fornitore provider di servizi internet

poi devi scrivere nel file /etc/resolv.conf oppure /etc/ppp/resolv.conf

esempio per telecom

nameserver 194.243.154.51

cioki
04-02-2008, 19:40
Ciao, ti volevo ringraziare ma come d'incanto questo pomeriggio sono riuscito a collegarmi....
n.b. ho fatto il file resolv.conf in /etc -
sbagliavo in quanto io facevo la cartella resolv.conf
pultroppo sono alle prime armi

Loading