PDA

Visualizza la versione completa : [DEB] Non risolve i domini


SMASH
13-02-2008, 21:50
Ciao, ho una debian Etch che uso come server quasi esclusivamente per amule, gestisco il tutto senza monitor in ssh.
Ho notato però che internet funziona, infatti il mulo scarica benissimo, il problema è che non risolve i domini!
Cioè se faccio un ping su google, oppure voglio aggiornare il sistema, non funziona.

Credo di aver controllato tutte le cose principali: resolv.conf primo fra tutti.
Ho provato con gli opendns ma nulla.... Il gateway lo pinga benissimo...
Non so dove sbattere la testa...

Qualche dritta??

Grazie
Marco.

noodles25
14-02-2008, 13:30
oh non so, magari non c'entra nulla però io avevo su debian/ubuntu problemi con il mio nuovo router-modem-adsl: ho dovuto aggiungere questa riga:
prepend domain-name-servers 212.216.112.112,212.216.172.62;

al file /etc/dhcp3/dhclient.conf e poi:
sudo ifdown eth0
sudo ifup eth0


spero ti sia utile

ciao

SMASH
14-02-2008, 15:39
:cry: nulla

Io comunque avevo degli indirizzi diversi...



# Configuration file for /sbin/dhclient, which is included in Debian's
# dhcp3-client package.
#
# This is a sample configuration file for dhclient. See dhclient.conf's
# man page for more information about the syntax of this file
# and a more comprehensive list of the parameters understood by
# dhclient.
#
# Normally, if the DHCP server provides reasonable information and does
# not leave anything out (like the domain name, for example), then
# few changes must be made to this file, if any.
#

#send host-name "andare.fugue.com";
#send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
#send dhcp-lease-time 3600;
#supersede domain-name "fugue.com home.vix.com";
#prepend domain-name-servers 127.0.0.1;
request subnet-mask, broadcast-address, time-offset, routers,
domain-name, domain-name-servers, host-name,
netbios-name-servers, netbios-scope, interface-mtu;
#require subnet-mask, domain-name-servers;
#timeout 60;
#retry 60;
#reboot 10;
#select-timeout 5;
#initial-interval 2;
#script "/etc/dhcp3/dhclient-script";
#media "-link0 -link1 -link2", "link0 link1";
#reject 192.33.137.209;

#alias {
# interface "eth0";
# fixed-address 192.5.5.213;
# option subnet-mask 255.255.255.255;
#}

#lease {
# interface "eth0";
# fixed-address 192.33.137.200;
# medium "link0 link1";
# option host-name "andare.swiftmedia.com";
# option subnet-mask 255.255.255.0;
# option broadcast-address 192.33.137.255;
# option routers 192.33.137.250;
# option domain-name-servers 127.0.0.1;
# renew 2 2000/1/12 00:00:01;
# rebind 2 2000/1/12 00:00:01;
# expire 2 2000/1/12 00:00:01;
#}

#prepend domain-name-servers 208.67.222.222,208.67.220.220;
prepend domain-name-servers 212.216.112.112,212.216.172.62;

SMASH
15-02-2008, 15:20
Nessuno??!? :dhò:

Loading