PDA

Visualizza la versione completa : pclinuxos su presario, scheda wifi e video


psykopear
14-02-2008, 20:07
Mia sorella sta felicemente passando a linux (sul portatile, presario c737el)dopo aver provato quello scempio di vista, che anche da profana di computer si è resa conto essere inutilizzabile. Allora gli ho installato pclinuxos, gli ho dato una mano nella configurazione grafica, però mancano due cosette: i giusti driver per la scheda video e la wireless:

Scheda video:
E' una intel integrata (la 965), dal pannello di controllo ho impostato "i810 or later" che pare sia l'opzione più opportuna, e come driver ho provato quelli che mi propone il centro di controllo (i7equalcosa, e intel) ma non vanno, nessuno dei due. Se mi dite quale parte del xorg.0.log dovrei postare per aiutarvi a capire vi sarei grato, dato che è lunghissimo s icuramente non è tutto necessario.

Scheda wireless:
Si ovrebbe accendere premendo un pulsantino in alto, però se lo premo rimane spento (lucetta arancione) e quindi non riesco a configurarla, mentre sul vista preinstallato la lucetta diventa blu e sembra funzionare, ma non ho ancora potuto provare, dato che qui il wireless non arriva, ma gli sarà neccessario all'uni.
la scheda wireless è sempre integrata, però non so dirvi altro, se mi date una mano anche a capire il modello mi sa che si risolve prima.

Grazie a tutti bye

edit: scusate per il titolo un po complesso :D

psykopear
14-02-2008, 20:29
Gia che ci siamo (ma è di secondaria importanza rispetto a scheda wireless e video) dovrei cercare di capire che webcam è quella integrata così da poter trovare il modo di installare i relativi driver.

PS: se do modprobe mi da command not found, su pclinuxos il comando è diverso da quello di ubuntu? Mi pare tanto strano

mykol
14-02-2008, 23:03
lo dai da root ?

psykopear
14-02-2008, 23:20
Originariamente inviato da mykol
lo dai da root ?

a, quindi devo proprio essere root per far partire queste utility. Ok, ho imparato un altra cosa :D

psykopear
14-02-2008, 23:32
[root@localhost giulia]# hwinfo --gfxcard
10: PCI 02.0: 0300 VGA compatible controller (VGA)
[Created at pci.296]
UDI: /org/freedesktop/Hal/devices/pci_8086_2a02
Unique ID: _Znp.XZlQkpRmfbB
SysFS ID: /devices/pci0000:00/0000:00:02.0
SysFS BusID: 0000:00:02.0
Hardware Class: graphics card
Model: "Hewlett-Packard Company 965 GM"
Vendor: pci 0x8086 "Intel Corporation"
Device: pci 0x2a02 "965 GM"
SubVendor: pci 0x103c "Hewlett-Packard Company"
SubDevice: pci 0x30d9
Revision: 0x03
Memory Range: 0x91000000-0x910fffff (rw,non-prefetchable)
Memory Range: 0x80000000-0x8fffffff (rw,prefetchable)
I/O Ports: 0x30d0-0x30d7 (rw)
IRQ: 11 (no events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: "pci:v00008086d00002A02sv0000103Csd000030D9bc03sc00 i00"
Driver Info #0:
XFree86 v4 Server Module: intel
Driver Info #1:
XFree86 v4 Server Module: intel
3D Support: yes
Extensions: dri
Config Status: cfg=new, avail=yes, need=no, active=unknown

11: PCI 02.1: 0380 Display controller
[Created at pci.296]
UDI: /org/freedesktop/Hal/devices/pci_8086_2a03
Unique ID: ruGf.2073efkQxC1
SysFS ID: /devices/pci0000:00/0000:00:02.1
SysFS BusID: 0000:00:02.1
Hardware Class: graphics card
Model: "Hewlett-Packard Company Display controller"
Vendor: pci 0x8086 "Intel Corporation"
Device: pci 0x2a03
SubVendor: pci 0x103c "Hewlett-Packard Company"
SubDevice: pci 0x30d9
Revision: 0x03
Memory Range: 0x91100000-0x911fffff (rw,non-prefetchable)
Module Alias: "pci:v00008086d00002A03sv0000103Csd000030D9bc03sc80 i00"
Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #10
[root@localhost giulia]#



[root@localhost giulia]# hwinfo --netcard
23: PCI 100.0: 0282 WLAN controller
[Created at pci.296]
UDI: /org/freedesktop/Hal/devices/pci_168c_1c
Unique ID: VCu0.7jT5h3Ou8wB
Parent ID: z8Q3.yjCEx5JbDxB
SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: network
Model: "Hewlett-Packard Company WLAN controller"
Vendor: pci 0x168c "Atheros Communications, Inc."
Device: pci 0x001c
SubVendor: pci 0x103c "Hewlett-Packard Company"
SubDevice: pci 0x137b
Revision: 0x01
Features: WLAN
Memory Range: 0x91300000-0x9130ffff (rw,non-prefetchable,disabled)
IRQ: 23 (14933 events)
Module Alias: "pci:v0000168Cd0000001Csv0000103Csd0000137Bbc02sc00 i00"
Driver Info #0:
Driver Status: ath_pci is active
Driver Activation Cmd: "modprobe ath_pci"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #13 (PCI bridge)

24: PCI 201.0: 0200 Ethernet controller
[Created at pci.296]
UDI: /org/freedesktop/Hal/devices/pci_10ec_8139
Unique ID: rBUF.9PjSIsrT6xB
Parent ID: 6NW+.o1FfZoLxn+0
SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:02:01.0
SysFS BusID: 0000:02:01.0
Hardware Class: network
Model: "Hewlett-Packard Company RTL-8139/8139C/8139C+"
Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
Device: pci 0x8139 "RTL-8139/8139C/8139C+"
SubVendor: pci 0x103c "Hewlett-Packard Company"
SubDevice: pci 0x30d9
Revision: 0x10
Driver: "8139too"
Driver Modules: "8139too"
Device File: eth0
I/O Ports: 0x1000-0x1fff (rw)
Memory Range: 0x91200000-0x912000ff (rw,non-prefetchable)
IRQ: 23 (14933 events)
HW Address: 00:1b:38:c2:57:45
Link detected: yes
Module Alias: "pci:v000010ECd00008139sv0000103Csd000030D9bc02sc00 i00"
Driver Info #0:
Driver Status: 8139too is active
Driver Activation Cmd: "modprobe 8139too"
Driver Info #1:
Driver Status: 8139cp is not active
Driver Activation Cmd: "modprobe 8139cp"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #18 (PCI bridge)
[root@localhost giulia]#

Qua dovrebbe andare se do il "modprobe 8139cp"??

psykopear
15-02-2008, 15:23
PS: quando vado al centro di controllo e gli dico "Connessione wireless", mi da errore
Impossibile trovare l'interfaccia di rete per la periferica scelta (con il driver ath_pci)
Invece da "Configura nuova interfaccia di rete", poi wireless, se gli dico di usare i driver consigliati mi da l'errore sopra, se invece provo ad installare i driver windows con ndiswrapper mi da "Per questa operazione è richiesto il file del firmware"

Loading