PDA

Visualizza la versione completa : come installare gcc


giù84
18-02-2008, 19:17
salve a tutti!ho installato wmware su windows XP e poi opensuse.
adesso (siccome devo esercitarmi con la programmazione c su linux) vorrei installare gcc.
Ho scaricato gcc4.0.4.tar.bz2, e adesso vorrei capire come, passo passo, devo installarlo. spero possiate aiutarmi...grazie

mykol
18-02-2008, 19:53
ma lo "devi" installare da sorgenti per esercizio ? Altrimenti penso che lo puoi più facilmente installare col "gestore di pacchetti" della tua distribuzione. Qual'è a proposito ?

giù84
21-02-2008, 13:08
ciao,
la distribuzione linux è opensuse.....scusate la mia ignoranza ma vorrei capire passo passo quali sono i comandi per installare gcc.
Devo installarlo dalla shell?
grazie anticipatamente per la risposta,ciao a tutti

paolino_delta_t
21-02-2008, 13:25
Originariamente inviato da giù84
ciao,
la distribuzione linux è opensuse.....scusate la mia ignoranza ma vorrei capire passo passo quali sono i comandi per installare gcc.
Devo installarlo dalla shell?
grazie anticipatamente per la risposta,ciao a tutti

no devi usare YaST per installare i pacchetti

nel pannello di controllo di SuSE c'è da qualche parte una voce che dice "Installa software", cliccaci sopra, si aprirà il gestore dei pacchetti, scorri la lista, trova gcc e installalo

giù84
21-02-2008, 18:14
scuaste ancora...
ho provato ad installare gcc con YaST...però:
nella voce cerca ho inserito gcc, così compare una lista di pacchetti che seleziono per installarli. Non capisco però questa ricerca dove la effettua, perchè sono sicura che non vede il file gcc-4.0.4.tar.bz2 che ho messo nella cartella /home/utente/Documents/compilatore.
Infatti quando seleziono i pacchetti e clicco su accetta mentre sta per installare mi dice di inserire il cd di suse.
potete aiutarmi?
grazie mille.

panta1978
21-02-2008, 18:27
Originariamente inviato da giù84
scuaste ancora...
ho provato ad installare gcc con YaST...però:
nella voce cerca ho inserito gcc, così compare una lista di pacchetti che seleziono per installarli. Non capisco però questa ricerca dove la effettua, perchè sono sicura che non vede il file gcc-4.0.4.tar.bz2 che ho messo nella cartella /home/utente/Documents/compilatore.
Infatti quando seleziono i pacchetti e clicco su accetta mentre sta per installare mi dice di inserire il cd di suse.
potete aiutarmi?
grazie mille.
È normale, YaST si connette a degli archivi on-line e/o al DVD di installazione. Il file .tar.bz2 non ti serve.
Inserisci il DVD di OpenSuse e vai tranquilla.

giù84
21-02-2008, 18:40
sono sempre io...
il problema è che non ho il dvd di installazione e non ho il collegamento ad internet perchè suse è installato su WMware in una piccola partizione di 5G circa.
Come faccio?

mykol
21-02-2008, 19:01
Parafrasando il logo di panta87 che ti ha risposto sopra.

Niet, wi can't ! Non si può fare !


In Italiano: forse sarebbe meglio non fare politica su questo forum ! Mi pare che sarebbe forse anche più aderente allo spirito ed alle regole del forum stesso.
A proposito, che ne dicono i mod ?
A dire la verità, mi stupivo che non fosse ancora successo ...


Tornando in topic, la cosa migliore sarebbe procurarsi il cd di suse, della stessa identica versione.

Si potrebbe anche installare il pacchetto che hai scaricato, ma non è tanto cosa da principiante, sopratutto se questo ha bisogno di altri pacchetti come dipendenze, quindi a loro volta da scaricare ed installare prima.

paolino_delta_t
21-02-2008, 19:38
Originariamente inviato da giù84
sono sempre io...
il problema è che non ho il dvd di installazione e non ho il collegamento ad internet perchè suse è installato su WMware in una piccola partizione di 5G circa.
Come faccio?

si può fare scaricando il pacchetto da uno di questi repository ( a seconda della versione di SuSE che utilizzi ):

10.3 -> http://download.opensuse.org/distribution/10.3/repo/oss/
10.2 -> http://download.opensuse.org/distribution/10.2/repo/oss/
10.1 -> http://download.opensuse.org/distribution/SL-10.1/inst-source/
10.0 -> http://download.opensuse.org/distribution/SL-10.0-OSS/inst-source/

però così facendo perdi di fatto tutti i vantaggi tipici dell'installazione automatica, infatti dovrai scaricare anche tutti i pacchetti da cui gcc-4.2-24.i586.rpm dipende, è un lavoraccio

però non capisco perchè non hai la rete visto che SuSE è installato sotto Vmware ed è possibile collegarlo alla stessa rete usate da Windows

Loading