PDA

Visualizza la versione completa : Aiuto su debug rete lan


gianiaz
21-02-2008, 10:31
Ciao ragazzi, ho la seguente situazione:

Linea Fastweb -> Server Linux Debian (Gateway) -> N pc che si connettono a internet

Sul server linux ho come configurazione delle schede di rete (/etc/network/interfaces/)



# The primary network interface
auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet static
address 192.168.0.1
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255


Sullo stesso server ho configurato un server dhcp con la seguente configurazione:



subnet 192.168.0.0 netmask 255.255.255.0 {
range 192.168.0.10 192.168.0.50;
default-lease-time 86400;
max-lease-time 86400;
# Default gateway
option routers 192.168.0.1;
option ip-forwarding off;
option broadcast-address 192.168.0.255;
option subnet-mask 255.255.255.0;
option domain-name-servers xxx.xxx.xxx.xxx;
option netbios-name-servers 192.168.0.1;
}


Ora passo al problema:

In pratica questo server va da almeno un paio d'anni senza problemi, da un paio di giorni succede che dopo un periodo di inattività della rete locale (ad esempio la mattina dopo la nottata), che il server perda il suo indirizzo (quello sulla eth1 e si prenda un ip a caso, ad esempio 192.168.0.47), e ovviamente tutti i pc della rete locale perdono il collegamento a internet, perchè il dhcp è configurato in modo da distribuire come default gateway 192.168.0.1).

Quello che noto è che prende un indirizzo che è nel range del server dhcp, ma mi chiedo cosa succeda, visto che la eth1 non è configurata per richiedere l'indirizzo in dhcp.

Nella stessa rete locale c'è un access point, ma ho controllato e il server dhcp è disattivato.

Quindi la mia domanda è :

C'è un modo per capire da qualche log chi è che rilascia il nuovo indirizzo ip?
Secondo voi quale può essere il problema?

Grazie a tutti.

Loading