PDA

Visualizza la versione completa : Debian ed errore durante installazione .run


claudiocrack
13-03-2008, 03:33
Debian Etch
dopo aver smadonnato per l' accelerazione grafica tento l' installazione dell' unico gioco che uso su pc Enemy Territory e guardate che mi succede :dh:

Sapete di cosa si tratta?? :confused:



debian:/home/lalo/enemy territory# ls
et-linux-2.55.x86.run
debian:/home/lalo/enemy territory# ./et-linux-2.55.x86.run
Verifying archive integrity... All good.
Uncompressing Enemy Territory 2.55.............................................. .................................................. .................................................. .................................................. .................................................. .................................................. ...
/root/.setup3661: error while loading shared libraries: libgtk-1.2.so.0: cannot open shared object file: No such file or directory
./setup.sh: line 143: 3685 Segmentation fault "$setup" "$@" 2>>$NULL
The setup program seems to have failed on x86/glibc-2.1

See http://zerowing.idsoftware.com/linux/ for troubleshooting
debian:/home/lalo/enemy territory#





ace :ciauz:

andy caps
13-03-2008, 07:28
installa le libgtk1.2-dev libgtk2.0-dev

claudiocrack
13-03-2008, 12:16
fatto... :(


debian:/home/lalo/enemyterritory# ./et-linux-2.55.x86.run
Verifying archive integrity... All good.
Uncompressing Enemy Territory 2.55.............................................. .................................................. .................................................. .................................................. .................................................. .................................................. ...
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

./setup.sh: line 143: 4611 Segmentation fault "$setup" "$@" 2>>$NULL
The setup program seems to have failed on x86/glibc-2.1

See http://zerowing.idsoftware.com/linux/ for troubleshooting
debian:/home/lalo/enemyterritory#

che tristezza :bh:

andy caps
13-03-2008, 14:13
:bh: devi scaricare et-linux-2.60.x86.run

la versione 2.55 troppo vecchia per le moderne distro'
poi manco riesci a giocarci perche' i server non l' accettano

anche la 2.60 mi sembra vada aggiornata con una piccola patch da copiare semplicemente nella cartella di destinazione

claudiocrack
13-03-2008, 14:21
La patch la ho gia solo che il file di installazione (run) il 2.55 e poi patchandolo con il 2.60 dovrebbe andare solo che se nn riesco prima a lanciare il 2.55 nn posso patchare nulla :cry:




Grazie comunque provo a fare una copia brutale della cartella ./dfsfndon.run creata su un altro sistema.




grazie ciao

:ciauz:

claudiocrack
13-03-2008, 14:35
ha funzionato...ahhahaha

ho messo una vm con mandriva 2007 ho lanciato il .run mi ha creato la cartella ho copiato la cartella sul mio sistema debian e funziona alla grande....


una soluzione un' p rozza ma va...


Grazie a tutti



:ciauz:

weseven
13-03-2008, 15:05
"Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified"

just for testing purposes, prova a dare "xhost +" da utente normale e poi a rilanciare il setup da root.

claudiocrack
13-03-2008, 16:07
Funziona :oVVoVe:

ma cosa cavolo era???

xhost + mi restituisce

Access control disabled, clients can connect from any hosts

lancio il run e funziona tutto alla grande...

ti prego spiegami cosa era...



ace :ciauz:

weseven
13-03-2008, 18:17
xorg un server, e come utente ti ci connetti.
ora, di default le connessioni "esterne" sono disabilitate, perci se cerchi con un altro utente di connetterti al server del tuo utente, vieni spedito fuori a calci (anche se sei root, come hai visto).
con xhost + disabiliti il controllo degli accessi per la sessione in corso ( sicuro farlo se non fai da server/non sei in ambienti strani).
avresti potuto dare anche xhost +localhost, e permettere gli accessi da localhost (la tua macchina).
questo ovviamente per quanto riguarda la sessione dalla quale esegui i comandi (che vanno eseguiti dall'utente che connesso al server X, aka il tuo utente).
perci quando vedi quell'errore, semplicemente dai xhost + (o +localhost) e dovresti risolvere.

per rendere la modifica permanente, bisogna editare un file, ma al momento non ricordo i dettagli (/etc/X11/X0.hosts?) per cui al limite fai una ricerca

:ciauz:

claudiocrack
13-03-2008, 19:47
Adesso ho capito...avevo intuito una cosa del genere mi sfuggiva il fatto che il setup creasse un altro utente che si collegava al server del mio utente.
Quel problema infatti lo avevo da konsole per molti programmini che mi aprivano una "connessione" con X.


Grazie mille per l' aiuto e per le spiegazioni... c' sempre da imparare...


ciao :ciauz:

Loading