PDA

Visualizza la versione completa : [Ubuntu 7.10] problema con Nvidia driver


Il_Drugo
06-04-2008, 21:50
Salve a tutti!

Da poco sono passato ad Ubuntu, quindi si....sono un niubbo :)
Cmq, ho installato Envy per effettuare l'installazione automatica dei drivers Nvidia.

Tutto funziona perfettamente, addirittura partono correttamente gli effetti desktop e il dual monitor in TwinView.

L'unico problema Ŕ che ogni TOT riavvii torna in modalitÓ grafica standard (800x600, single monitor) e carica i driver Nvidia open source di Ubuntu....

Entrando nel terminale virtuale fermo GDM e reinstallo i drivers con Envy e tutto funziona perfettamente....ma poi....

Ecco alcune info:

scheda video: Nvidia GeForce 7600GT

contenuto del file /etc/X11/xorg.conf:


Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation G70 [GeForce 7600 GT]"
Driver "nvidia"
BusID "PCI:3:0:0"
VideoRam 256000
EndSection

Section "Monitor"
Identifier "ASUS MB19SE"
Option "DPMS"
HorizSync 24-80
VertRefresh 55-75
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G70 [GeForce 7600 GT]"
Monitor "ASUS MB19SE"
DefaultDepth 24
SubSection "Display"
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
Option "TwinView" "True"
Option "TwinViewOrientation" "RightOf"
Option "UseEdidFreqs" "True"
Option "MetaModes" "1280x1024,1280x1024; 1024x768,1024x768"
Option "UseDisplayDevice" "string" #replace 'string' with either 'DFP' (Digital flat panel connected via DVI port), 'CRT' (any monitor that is connected via VGA ports), or 'TV'
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection


contenuto del file /etc/default/linux-restricted-modules-common:


DISABLED_MODULES="nv nvidia_new"


Non mi intendo molto di Linux ma credo che quella riga nel linux-restricted-modules-common dovrebbe impedire di usare i driver Nvidia di Ubuntu al boot....giusto?

Vi prego illuminatevi perchŔ il problema Ŕ fastidiosetto ed Ŕ l'ultimo passo per abbandonare per sempre Windows (se non in VirtualBox emulation).

thx

nifriz
07-04-2008, 11:55
Ciao,
avevo lo stesso problema con la mia GeForce 440 MX, ma Ú poi magicamente scomparso da solo con questa procedura:
1- Disinstallati da synaptic tutti driver NVIDIA (cercando NVIDIA come chiave)

2- apt-get clean

3- Rilanciato ENVY e reinstalli driver da zero.

Prova e poi facci sapere :ciauz:

francofait
07-04-2008, 13:22
Originariamente inviato da nifriz
Ciao,
avevo lo stesso problema con la mia GeForce 440 MX, ma Ú poi magicamente scomparso da solo con questa procedura:
1- Disinstallati da synaptic tutti driver NVIDIA (cercando NVIDIA come chiave)

2- apt-get clean

3- Rilanciato ENVY e reinstalli driver da zero.

Prova e poi facci sapere :ciauz:

╚ sufficente inserire i driver inutili nella blacklist

Il_Drugo
08-04-2008, 09:26
Ho messo in blacklist i vecchi drivers, fatto un clean con Envy e ora SEMBRA funzionare....speriamo.

Grazie :unz:

Loading