PDA

Visualizza la versione completa : Problema con HD esterno


mauretto
08-04-2008, 23:57
Salve a tutti,
ho una SUSE 10.3 e ho un HD esterno da 80 Gbyte.
gi la seconda o terza volta che dopo diverso tempo di utilizzo dell'HD esterno come repository per i file utilizzati da aMule, la cartella contenente gli stessi "impazzisce".
In passato, quando era formattato come FAT32, avevo "accusato" del problema Windows, sistema operativo a cui ogni tanto collegavo lo stesso HD per condividere i file.
Ma ora, formattato come Reiser, la cartella nascosta .aMule mi si magicamente trasformata in un semplice file.
Semplice in un certo senso, dato che se faccio un
ls -la
il risultato che ottengo :
?rwxr-xr-x 4100 268440552 268439652 268439552 20 apr 2016 .aMule
dove il "?" non si sa che sta ad indicare.
Inoltre la dimensione totale era ben pi grande dei 268 Mbyte riportati qui...
Non riesco a spiegarmi il perch di questa cosa e soprattutto mi preoccupa il fatto che (immagino) non possa pi fare nulla per i dati che erano salvati li dentro. Giusto?
Ulteriore stranezza che le altre cartelle contenute nell'HD non hanno subito alterazione alcuna.
Qualcuno sa dirmi cosa pu essere successo?

Grazie e buonanotte

McGuolo
09-04-2008, 11:34
E' possibile che sia stata smontata in maniera non corretta, o non smontata prima che fosse staccata dal pc?

mauretto
09-04-2008, 13:27
Mmm...
Ti dir... in effetti ogni volta che lo collego o lo scollego non lo monto/smonto mai a mano...
Ma questo perch "dovrebbe" (e sottolineo dovrebbe) essere configurato l'automount sul mio pc...
Questo che tu mi stai dicendo una cosa che non ho mai preso in considerazione ma che potrebbe essere proprio la causa dei miei diversi problemi (anche del fatto che ogni tanto quando lo collego me lo monta in readonly).
Ma allora mi vuoi dire che l'automount non fa tutto in automatico? :incupito: :berto:

McGuolo
09-04-2008, 14:49
Onestamente non ho mai usato l'automount, ma se qualche volta ti monta il disco in read only e' sintomo che non era in uno stato consistente tale da consentire un mount pulito.

Ovviamente il disco era configurato per l'automount, immagino (sara' una domanda stupida, ma non si sa mai! :D )

Comunque secondo il mio modesto parere non ti conviene utilizzare l'automount su una periferica che utilizzi per aMule, credo che inserisca un notevole tempo di overhead dovuto ai continui mount/unmount prima e dopo ogni scrittura e lettura, e calcolando che un programma p2p scrive e legge di continuo, fa un po' i conti.

mauretto
22-04-2008, 13:36
Ok, perfetto.
Ma allora potrei sapere una volta per tutte cosa devo scrivere in fstab per far s che questo cavolo di HD mi venga letto e non montato se non manumente, mentre se collego una semplice pennetta usb possa essere montata in automatico???

Aiutatemi vi prego, non ce la faccio pi a continuare a formattare ogni volta che mi si intoppa.... :dh: :dh: :dh:

francofait
22-04-2008, 14:08
Originariamente inviato da mauretto
Ok, perfetto.
Ma allora potrei sapere una volta per tutte cosa devo scrivere in fstab per far s che questo cavolo di HD mi venga letto e non montato se non manumente, mentre se collego una semplice pennetta usb possa essere montata in automatico???

Aiutatemi vi prego, non ce la faccio pi a continuare a formattare ogni volta che mi si intoppa.... :dh: :dh: :dh:

al posto di auto metti noauto

aleritty
22-04-2008, 14:24
In realt non ti serve togliere l'automount, in quanto te lo monta quando lo colleghi e te lo smonta quando gli dai il comando! (magari se lo fai da terminale vedi anche se ci sono errori in proposito!)

Quindi secondo me ti conviene lasciarlo in automount, ma smontarlo ogni volta prima di scollegarlo!

Non ti inserisce ritardi nei cicli di scrittura infatti suse lo monta e lo lascia montato, non lo monta ogni volta che deve scrivere...

Loading