PDA

Visualizza la versione completa : Kernel Panic!


Bugu
11-04-2008, 22:30
All'improvviso la mia Mepis da un errore: dopo aver selezionato dal bootloader la Mepis col mio ultimo kernel aggiornato, all'avvio si inchioda col seguente messaggio: "Kernel Panic - not syncing: VFS: unable to mount root fs on unknown-block (0,0)"

Non ho fatto niente di particolare, l'ultima cosa che ho fatto stata di modificare la password di root.
Le versioni precedenti per del kernel me le carica.
Aiuto!!!
:dh:

Bugu
11-04-2008, 22:47
il mio boot/grub/menu.lst questo:


timeout 15
color cyan/blue white/blue
foreground ffffff
background 0639a1

gfxmenu /boot/grub/message

title MEPIS at sda4, newest kernel
root (hd0,3)
kernel /boot/vmlinuz root=/dev/sda4 nomce quiet splash vga=791
boot

title Microsoft Windows XP Professional at sda2
rootnoverify (hd0,1)
chainloader +1

title MEPIS at sda4, previous kernel (if any)
root (hd0,3)
kernel /boot/vmlinuz.old root=/dev/sda4 nomce quiet splash vga=791
boot

title MEPIS at sda4, kernel 2.6.22-1-mepis64-smp
root (hd0,3)
kernel /boot/vmlinuz-2.6.22-1-mepis64-smp root=/dev/sda4 nomce quiet splash vga=791
boot

title Windows Vista/Longhorn (loader) at sda1
rootnoverify (hd0,0)
chainloader +1

title MEMTEST
kernel /boot/memtest86+.bin

francofait
11-04-2008, 23:35
Dov' il kernel nuovo che hai installato , in questo menu.lst non c' ?

Se il primo della lista , l'errore li , hai usato un kernel debian , e il kernel debian richiede tassativamente l' initrd , quindi pi che giustificato il kernel panick da parte sua

Bugu
11-04-2008, 23:38
Dovrebbe essere in "newest". Me lo sono ritrovato in cima alla lista...

Se uso quello precedente ("if any") mi avvia. Ora la cosa strana che la WIFI me la avvia solo da root
:confused:

Bugu
11-04-2008, 23:39
Se esco da root e entro come user me la lascia avviata la WIFI, ma non riesco ad avviarla direttamente dallo user

francofait
11-04-2008, 23:40
Se il primo della lista , l'errore li , hai usato un kernel debian , e il kernel debian richiede tassativamente l' initrd, i kernel di mepis no. , quindi pi che giustificato il kernel panick da parte sua

Bugu
11-04-2008, 23:41
Quindi entro sempre con la precedente? E perch non mia avvia la WIFI da user?

francofait
11-04-2008, 23:43
Perch i driver del wifi li hai installati sul nuovo.

Bugu
11-04-2008, 23:43
Da root nel menu delle "trusted connections" mi trovo la mia WIFI, mentre da user (anche con la WIFI avviata prima da root) nelle "trusted connection" non ho nulla

Bugu
11-04-2008, 23:44
Ma i driver li ho installati, altrimenti la WIFI non partirebbe, no?
E' che mi parte solo da root

Loading