PDA

Visualizza la versione completa : [ubuntu]Installare software


giuseppe500
06-05-2008, 09:32
Ciao.
Conoscete una guida o un tutorial che spieghi come si installano le applicazioni in linux?
Mi piacerebbe imparare ad installarle a manina , in quanto i repository molte volte sono imballati e non si riesce ad installare da synaptyc.
Mollto meglio scaricarsi il tar e installarlo.
Ma come?
Grazie.

livellozero
06-05-2008, 10:06
Nulla vieta in linux di installarsi un sorgente, per che io sappia, per distro tipo ubuntu, meglio usare i repository ufficiali! Anche distro tipo slackware e arch oppure gentoo, che utilizzano i file sorgenti per la compilazione dei programmi, hanno dei repository propri da cui attingere appunto i sorgenti. Questo evita alcuni problemi, legati soprattutto alle dipendenze dei pacchetti. Comunque, i comandi tipo, di solito sono
tar -xzvf nomepacchetto.tar.gz (per decomprimere i file.tar.gz)
cd nomecartella (per entrare nella cartella creata dalla decompressione del file.gz)
.configure (non sempre necessario)
make
make install

tar -xjvf nomepacchetto.tar.bz2 (per decomprimere i file.tar.bz2)
Questo per i formati pi comuni di compressione dei sorgenti (tar.gz e tar.bz2)

nifriz
06-05-2008, 10:10
Non posso che appoggiare al 100% LivelloZero.
Se vuoi evitarti un sacco di problemi, ogni qual volta sia possibile, attingi dai repository!
Il software si installa con le corrette dipendenze e in versioni stabili!

:ciauz:

borgio3
06-05-2008, 17:49
Non riesco a capire che problemi puoi avere incontrato con Ubuntu, che ha dalla sua il vantaggio di usare Synaptic che, in quanto a facilit e affidabilit, non ha rivali.
Ricarichi le repositories, cerchi il pacchetto che vuoi installare, leggi quello che ti dice a proposito delle dipendenze e dei pacchetti accessori, confermi e applichi le procedure.
Tempo ... diciamo due minuti, ed hai il tuo bel programma installato.

What's problem?

Se installi un pacchetto da sorgente ed hai fatto qualche maronata od hai dimenticato una dipendenza e non installi una mazza.

Mi sembra una cosa da Ufficio Complicazioni Affari Semplici.

Ciao Ciao :-)

giuseppe500
08-05-2008, 23:47
Il fatto ragazzi che in Synaptic non riesco a trovare envy,un programma per la scheda video ati.
Mentre dal sito(di envy)riesco a scaricare un .dev , che manco a dirlo se tento di installarlo cosi:
sudo dpkg -i envy*.deb
mi dice che mancano delle dipendenze e qui mi sono fermato:
dpkg: problemi con le dipendenze impediscono la configurazione di envy:
envy dipende da build-essential; comunque:
Il pacchetto build-essential non installato.
envy dipende da debhelper; comunque:
Il pacchetto debhelper non installato.
envy dipende da dh-make; comunque:
Il pacchetto dh-make non installato.
envy dipende da dpatch; comunque:
Il pacchetto dpatch non installato.
envy dipende da dpkg-dev; comunque:
Il pacchetto dpkg-dev non installato.
envy dipende da fakeroot; comunque:
Il pacchetto fakeroot non installato.
envy dipende da libstdc++5; comunque:
Il pacchetto libstdc++5 non installato.
envy dipende da module-assistant; comunque:
Il pacchetto module-assistant non installato.
envy dipende da xserver-xorg-dev; comunque:
Il pacchetto xserver-xorg-dev non installato.
dpkg: errore processando envy (--install):
problemi con le dipendenze - lasciato non configurato
Sono occorsi degli errori processando:
envy

psykopear
09-05-2008, 00:09
Originariamente inviato da giuseppe500
Il fatto ragazzi che in Synaptic non riesco a trovare envy,un programma per la scheda video ati.
Mentre dal sito(di envy)riesco a scaricare un .dev , che manco a dirlo se tento di installarlo cosi:
sudo dpkg -i envy*.deb
mi dice che mancano delle dipendenze e qui mi sono fermato:
dpkg: problemi con le dipendenze impediscono la configurazione di envy:
envy dipende da build-essential; comunque:
Il pacchetto build-essential non installato.
envy dipende da debhelper; comunque:
Il pacchetto debhelper non installato.
envy dipende da dh-make; comunque:
Il pacchetto dh-make non installato.
envy dipende da dpatch; comunque:
Il pacchetto dpatch non installato.
envy dipende da dpkg-dev; comunque:
Il pacchetto dpkg-dev non installato.
envy dipende da fakeroot; comunque:
Il pacchetto fakeroot non installato.
envy dipende da libstdc++5; comunque:
Il pacchetto libstdc++5 non installato.
envy dipende da module-assistant; comunque:
Il pacchetto module-assistant non installato.
envy dipende da xserver-xorg-dev; comunque:
Il pacchetto xserver-xorg-dev non installato.
dpkg: errore processando envy (--install):
problemi con le dipendenze - lasciato non configurato
Sono occorsi degli errori processando:
envy

gli stessi identici errori li avresti installando da sorgenti. Le dipendenze di un pacchetto le devi comunque installare, se hai ubuntu probabilmente basta dare doppio click sul pacchetto, e ti dovrebbe aprire il gestore pacchetti per quello, che ti installa anche le dipendenze se non ricordo male. Senn ti davi installare da synaptic ognuno di quei pacchetti li elencati

francofait
09-05-2008, 00:34
se hai installato ubuntu 8 , envy non ti serve , sul lato destro del pannello accanto al tuo nome utente trovi un ' icona per l' installazione dei driver con restrizioni .
I driver per le tue schede non solo grafiche e non solo ati o Nvidia si installano da li

panta1978
09-05-2008, 08:34
Originariamente inviato da livellozero
Comunque, i comandi tipo, di solito sono
tar -xzvf nomepacchetto.tar.gz (per decomprimere i file.tar.gz)
cd nomecartella (per entrare nella cartella creata dalla decompressione del file.gz)
.configure (non sempre necessario)
make
make install

tar -xjvf nomepacchetto.tar.bz2 (per decomprimere i file.tar.bz2)
Questo per i formati pi comuni di compressione dei sorgenti (tar.gz e tar.bz2)

Quoto anch'io livellozero ed aggiungo: usualmente nell'archivio tar.gz o quel che trovi un file readme, usualmente sufficientemente esaustivo.

raistlin76
09-05-2008, 08:53
Originariamente inviato da giuseppe500
Mi piacerebbe imparare ad installarle a manina , in quanto i repository molte volte sono imballati e non si riesce ad installare da synaptyc.


Mai trovato repository imballati in tre anni di Ubuntu. :dott:


Mollto meglio scaricarsi il tar e installarlo.


Molto peggio invece come ti stato spiegato in precedenza, l'installazione da sorgenti o tramite installer da farsi solo nel caso di software non presenti nei repository.


Il fatto ragazzi che in Synaptic non riesco a trovare envy,un programma per la scheda video ati.

Uso Ubuntu 7.10 e envy c', ecco l'output:

# sudo apt-cache search envy
[sudo] password for ricsvi03-admin:
alsa-tools-gui - GUI based ALSA utilities for specific hardware
envy - install the ATI or the NVIDIA driver

:bh: :bh:

rb
09-05-2008, 21:49
In ogni caso, per rimanere sul semplice, con Ubuntu se provi a fare doppio click sopra il .deb ti dovrebbe partire Gdebi, che permette di installare deb locali risolvendo automaticamente tutte le dipendenze.

Loading