PDA

Visualizza la versione completa : modulo spca5xx


BMMX
22-05-2008, 21:51
Ho una debian testing e non riesco ad installare il modulo spca5xx per la web cam. come posso fare?

GunMan
22-05-2008, 22:01
hai due alternative, entrambe semplici da attuare.

1) scarichi il pacchetto gspca-modules per il tuo kernel

2) scarichi il pacchetto gspca-source e fai il build + installazione mediante module assistant ( qui (http://www.debianclan.org/index.php?option=com_content&task=view&id=144&Itemid=38) per maggiori dettagli )

in entrambi i casi risolvi facilmente col tuo gestore di pacchetti.

:ciauz:

BMMX
22-05-2008, 23:23
Scusa se non l'ho detto prima ma la mia web cam una logitech quick cam e supporta i driver spca5xx. ho provato a fare quello che mi hai suggerito ma non va e poi il modulo spca5xx dal link http://mxhaard.free.fr/download.html non si possono scaricare

andy caps
22-05-2008, 23:45
apt-cache search gspca


dovrebbe trovarti i moduli per il tuo kernel

ad esempioio con sid vedo

gspca-modules-2.6.25-2-amd64 - Driver for webcams and digicams based on spca5xx [B]

GunMan
22-05-2008, 23:54
un appunto:

dire che qualcosa non va equivale a non dire nulla, fondamentale postare output di errori o warning nella loro completezza altrimenti molto complesso (se non impossibile) poter capire dove risiede il problema.

comunque i pacchetti che ti ho elencato primo sono esattamente i driver che ti occorrono, facendo un riepilogo passo passo:

installi il pacchetto gspca-source

# apt-get install gspca-source

compili i sorgenti e installi il .deb

# m-a auto-install gspca

carichi il modulo appena installato

# modprobe gspca

verifichi che esso sia stato correttamente caricato

$ lsmod | grep gspca

e dovresti avere un output simile


gspca 640868 0
videodev 26624 1 gspca
usbcore 106876 4 gspca,ehci_hcd,uhci_hcd


naturalmente se insorge qualche problema lungo il procedimento posta eventuali errori

:ciauz:

BMMX
23-05-2008, 00:36
Quando faccio "m-a auto-install gspca" mi da questo errore


m-a auto-install gspca

Updated infos about 1 packages
Getting source for kernel version: 2.6.22-3-k7
Kernel headers available in /lib/modules/2.6.22-3-k7/build
apt-get install build-essential
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso
Reading state information... Fatto
build-essential gi alla versione pi recente.
The following packages were automatically installed and are no longer required:
gspca-modules-2.6.22-3-k7
Use 'apt-get autoremove' to remove them.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

Done!
unpack
The source tarball could not be found!
Package gspca-source not installed?
Running "m-a -f get gspca-source" may help.
"/usr/share/modass/overrides/gspca-source" build KVERS=2.6.22-3-k7 KSRC=/lib/modules/2.6.22-3-k7/build KDREV=2.6.22-6.lenny1 kdist_image
find: "/usr/src/modules/gspca*": No such file or directory

GunMan
23-05-2008, 00:54
The source tarball could not be found!
Package gspca-source not installed?

non trova il pacchetto con i sorgenti gpsca-source che non installato, invece installato il seguente pacchetto gspca-modules-2.6.22-3-k7 che ti suggerisce di rimuovere

:ciauz:

Loading