PDA

Visualizza la versione completa : Urgente - Errore durante apt-get! Come risolvo?


nifriz
08-06-2008, 12:48
Ciao Ragazzi,
ho avuto la pessima idea di seguire una guida all'ottimizzazione di Ubuntu e mi si crashato il sistema... faccio ripartire, sembra tutto ok tranne i driver video.
Ho fatto partire envy e si bloccato il pc e riavviandosi non andava pi rete e video.
Dopo vari tentativi sono riuscito a far ripartire il tutto, ma si deve essere rovinato qualcosa nelle apt.
Vado per correggere e questo quello che ottengo:


nifriz@NifrizOnLinux:/etc/apt$ sudo apt-get -f install
Lettura della lista dei pacchetti in corso... Errore!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/it.archive.ubuntu.com_ubuntu_dists_hardy_universe_ i18n_Translation-it
E: La lista dei pacchetti o il file di status non possono essere letti o aperti.

Please, un aiutino :fagiano:

EDIT:
Aggiungo che uso la 8.04 di Ubuntu.
Kernel 2.6.24-17-generic (il -18 nn mi va pi :fagiano: )
Se serve altro ...

francofait
08-06-2008, 13:24
Originariamente inviato da nifriz
Ciao Ragazzi,
ho avuto la pessima idea di seguire una guida all'ottimizzazione di Ubuntu e mi si crashato il sistema... faccio ripartire, sembra tutto ok tranne i driver video.
Ho fatto partire envy e si bloccato il pc e riavviandosi non andava pi rete e video.
Dopo vari tentativi sono riuscito a far ripartire il tutto, ma si deve essere rovinato qualcosa nelle apt.
Vado per correggere e questo quello che ottengo:


nifriz@NifrizOnLinux:/etc/apt$ sudo apt-get -f install
Lettura della lista dei pacchetti in corso... Errore!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/it.archive.ubuntu.com_ubuntu_dists_hardy_universe_ i18n_Translation-it
E: La lista dei pacchetti o il file di status non possono essere letti o aperti.

Please, un aiutino :fagiano:

EDIT:
Aggiungo che uso la 8.04 di Ubuntu.
Kernel 2.6.24-17-generic (il -18 nn mi va pi :fagiano: )
Se serve altro ...

Per il kernel il -18 gi stato sostituito con -19.



prova con un dpkg-reconfigure apt
oppure reinstalla apt

http://www.mepisitalia.org/franco/mint/apt_0.7.9ubuntu17_i386.deb

lo metti su una dir di comodo poi:

dpkg --force-all -i *.deb

nifriz
08-06-2008, 13:27
Mi sa che mi tocca reinstallare:



dpkg-reconfigure apt
dpkg-query: errore di analisi, nel file "/var/lib/dpkg/available" vicino alla riga 1:
il nome del campo `emon' deve essere seguito da ':' (due punti)
/usr/sbin/dpkg-reconfigure: apt non installato

nifriz
08-06-2008, 13:31
Anche provando a forzare il pacchetto che mi hai passato ottengo errore:


dpkg: errore di analisi, nel file "/var/lib/dpkg/available" vicino alla riga 1:
il nome del campo `emon' deve essere seguito da ':' (due punti)


Ma non riesco a vedere il file indicato con gli editor di testo...

francofait
08-06-2008, 13:51
il file di configurazione di dpkg corrotto sembrerebbe sia l' avaiable , vai in /var/lib/dpkg e rinomina avaiable.old in avaiable sovrascrivendo il file danneggiato.
Se non fosse sufficente , rimane l' ultima carta ripristinare tutti i .old non il solo 'avaiable'
e recuperare da /var/backuper l' ultimo backupe di status (dpkg.status.x.gz o al limite dpkg.status.0 che quello iniziale al momento dell' installazione . (i .x.gz sono compressi , il .0 no )

nifriz
08-06-2008, 13:53
Avevo gi riprovato a ripristinare avaiable.old ma sembra anche quello aver problemi, ripristino tutti gli OLD e poi ti faccio sapere...

nifriz
08-06-2008, 14:19
Ho recuperato l'ultimo backup di stato e ho sovrascritto dpkg.status.0 , riavviato ma nulla, non funziona ancora...

nifriz
08-06-2008, 14:28
Brutalmente risolto cos:

sudo rm /var/lib/apt/lists/* -vf

:mame: :mame: :mame:

RETTIFICO:
Funziona APT, ma DPKG non funziona ancora... Com' possibile?

francofait
08-06-2008, 14:36
Originariamente inviato da nifriz
Brutalmente risolto cos:

sudo rm /var/lib/apt/lists/* -vf

:mame: :mame: :mame:

RETTIFICO:
Funziona APT, ma DPKG non funziona ancora... Com' possibile?

Provato a seguire il consiglio dell' avviso di errore:

dpkg: errore di analisi, nel file "/var/lib/dpkg/available" vicino alla riga 1:
il nome del campo `emon' deve essere seguito da ':' (due punti) editando 'avaiable' ?

nifriz
08-06-2008, 14:50
Si,
c'era una descrizione rimasta a met, l'ho cancellata ed ora l'erroe cambiato in:


dpkg-query: errore di analisi, nel file "/var/lib/dpkg/available" vicino alla riga 3 pacchetto `dhcp3-common':
valore per il campo `status' non consentito in questo contesto
/usr/sbin/dpkg-reconfigure: apt non installato


E se usassi il file di qualcun'altro? Potrebbe andare?

Loading