PDA

Visualizza la versione completa : LAMP (problemi con PHP)


Nunzi
16-07-2008, 19:24
Ciao Ragazzi,

ho ubuntu 8.04 e ho installato lamp (apache, php, mysql e phpmyadmin).
Penso che abbia dei problemi con php perch se vado su http://localhost mi appare il messaggio "It vworks!!" oppure su http://localhost/index.html la pagina index.html visualizzata correttamente quindi il server apache funziona. Se vado su http://localhost/index.php mi appare la finestra con "apri" o "salva", si vede che c' qlc che non va infatti nella cartella etc/apache2/ non c' il file php.ini!!!!!

Che devo fare???
Helppppppppppppppp
:cry: :cry:

Fatemi sapere. Grazie mille

:ciauz:

Tux7000
16-07-2008, 19:32
Il file php.ini si trova in
/etc/php5/apache2/

controlla con il comando:
less php.ini

e vedi se c' il parametro
engine = on

emmeb
17-07-2008, 16:55
Pi o meno devi installare (nell'esempio con apt-get):

apt-get install apache2 php5 php5-mysql libapache2-mod-php5

simon_91
17-07-2008, 18:15
segui questi appunti e di certo nn sbaglierai:

http://ubuntu-inside.blogspot.com/2007/07/installare-lamp-su-ubuntu-per-inesperti.html

ciao e buon lavoro.... :ciauz:

Nunzi
18-07-2008, 10:41
Nella cartella etc/php5/apache2/ non c' il file php.ini, ho solo la directory denominata "conf.d"... :(
Che devo fare??
Helpppp

Nunzi
18-07-2008, 10:44
Ho provato anche con la guida per inesperti ma il problema sempre php.ini!!!
Ho dovuto anche disinstallare lamp e reinstallato ma sempre uguale il file php.ini non c'!!
:confused:

:ciauz:

Tux7000
18-07-2008, 10:51
Allora, prova ad aprire la shell e digitare il comando:
locate php.ini

se proprio non c' ci deve essere un errore di installazione.

Al limite disinstalla tutto e prova ancora a seguire questa guida:
http://wiki.ubuntu-it.org/Server/Xampp

Ciao.

Nunzi
18-07-2008, 10:54
Grazieee.
Trovato da shell ma nella cartella non si vede!!!Non nascosta?!?!
:cry:

Sono alle prime esperienze su ubuntu... :D

:ciauz:

simon_91
18-07-2008, 10:54
vai qui e vedi se c'e:

/usr/share/doc/php5-common/examples/php.ini-recommended

se lo trovi dove ti ho detto lo puoi copiare in /etc/php5/apache2/php.ini da terminale in questo modo:

sudo cp /usr/share/doc/php5-common/examples/php.ini-recommended /etc/php5/apache2/php.ini

:ciauz:

Nunzi
18-07-2008, 10:58
Simon,
nella cartella da te indicata c' il file php.ini-recommended. Prima di copiarlo aspetto notizie da TUX :D

:ciauz:

Loading