PDA

Visualizza la versione completa : Problema xset e screensaver


denis76
18-07-2008, 12:32
Con questo comandi



xset -display :0 s 864000 864000
xset -display :0 s noblank


speravo di disabilitare il screensaver (impostandolo dopo 24h) di un tale pc che deve mostrare una sequenza di immagini h24.

Eseguendo perņ



xset -display :0 q


mi accorgo che sembra non si possa superare la soglia di 12032 secondi. Allego il risultato:



sintesi@TerminaleMaster:~$ xset -display :0 q
Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000000
auto repeat delay: 500 repeat rate: 30
auto repeating keys: 00ffffffdffffbbf
fadfffdfffdfe5ef
ffffffffffffffff
ffffffffffffffff
bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
acceleration: 2/1 threshold: 4
Screen Saver:
prefer blanking: no allow exposures: yes
timeout: 12032 cycle: 12032
Colors:
default colormap: 0x20 BlackPixel: 0 WhitePixel: 16777215
Font Path:
/usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
Standby: 43260 Suspend: 43320 Off: 43380
DPMS is Disabled
sintesi@TerminaleMaster:~$



Come posso fare per disabilitare ogni tipo di screensaver, ogni tipo di spegnimento del monitor eccetera? Attenzione! il pc ha solo xorg installato, non ha un desktop environment!

Mutato
18-07-2008, 13:02
Nel file .Xsession dell'utente che esegue X metti:



/usr/bin/X11/xset -dpms
/usr/bin/X11/xset s off


:ciauz:

denis76
22-07-2008, 08:45
Ho tenuto in prova i pc per un giorno e ha funzionato.
Ti ringrazio davvero tanto.

Loading