PDA

Visualizza la versione completa : EXT3-fs failed boot Debian


Gab-81
19-07-2008, 14:58
Salve a tutti,
all'avvio della mia Debian 4.0 noto che c'è un errore (che cmq non compromette il funzionamento del sistema) che vorrei capire da cosa dipende; ho questo messaggio:

EXT3-fs: mounted filesystem in ordered data mode
failed.

Da cosa dipende? Può essere risolto?

Grazie a tutti
Gab :ciauz:

francofait
19-07-2008, 18:19
Originariamente inviato da Gab-81
Salve a tutti,
all'avvio della mia Debian 4.0 noto che c'è un errore (che cmq non compromette il funzionamento del sistema) che vorrei capire da cosa dipende; ho questo messaggio:

EXT3-fs: mounted filesystem in ordered data mode
failed.

Da cosa dipende? Può essere risolto?

Grazie a tutti
Gab :ciauz:
erto basta editare il file /etc/fstab e vedere in quale delle partizioni è stato assegnato un fs errato e correggerlo. Soluzione spiccia lo metti 'auto' e sei sicuro che ne sbagli mai Non viene compromesso il funzionamento del SO perchè chiaramente l' errore non è sulle partizioni di sistema.

Gab-81
20-07-2008, 13:00
Spero di poter approfittare della tua disponibilità :zizi: ...allora per vedere su quale partizione ho problemi ho dato un dmesg | grep EXT3 con il seguente risultato:

EXT3-fs: mounted filesystem with ordered data mode.
EXT3 FS on hda6, internal journal
EXT3 FS on hda5, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
EXT3 FS on hda8, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
EXT3 FS on hda7, internal journal
EXT3-fs: mounted filesystem with ordered data mode.

quindi apparentemente nulla di sbagliato...e poi mi sono andato a vedere fstab ed ho tutti defaults nella colonna <options>...cambio tutto in auto?

Grazie


:ciauz:

francofait
20-07-2008, 13:26
Originariamente inviato da Gab-81
Spero di poter approfittare della tua disponibilità :zizi: ...allora per vedere su quale partizione ho problemi ho dato un dmesg | grep EXT3 con il seguente risultato:

EXT3-fs: mounted filesystem with ordered data mode.
EXT3 FS on hda6, internal journal
EXT3 FS on hda5, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
EXT3 FS on hda8, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
EXT3 FS on hda7, internal journal
EXT3-fs: mounted filesystem with ordered data mode.

quindi apparentemente nulla di sbagliato...e poi mi sono andato a vedere fstab ed ho tutti defaults nella colonna <options>...cambio tutto in auto?

Grazie


:ciauz:

il parametro ' defaults' non riguarda il fs ma i permessi , in auto metti il riconoscimento dei fs .

Gab-81
20-07-2008, 14:41
Niente...purtroppo anche mettendo "auto", il risultato non cambia...se può essere utile ho il filesystem organizzato in questo modo:

- una partizione per /boot;
- una partizione per /root;
- una partizione per /usr (quella che genera l'errore!!!);
- una partizione per /home.

Grazie ancora
:ciauz:

francofait
20-07-2008, 16:15
Originariamente inviato da Gab-81
Niente...purtroppo anche mettendo "auto", il risultato non cambia...se può essere utile ho il filesystem organizzato in questo modo:

- una partizione per /boot;
- una partizione per /root;
- una partizione per /usr (quella che genera l'errore!!!);
- una partizione per /home.

Grazie ancora
:ciauz:

edita fstab e controlla la sintassi , se usr genera l' errore , l'errore in quella riga chiaramente c'è.

Gab-81
20-07-2008, 18:11
Nel file fstab io sinceramente non trovo errori, avendo anche cercato per la rete qualche guida che spiegasse la sua gestione...eccolo:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda6 / ext3 defaults,errors=remount-ro 0 1
/dev/hda5 /boot ext3 defaults 0 2
/dev/hda8 /home ext3 defaults 0 2
/dev/hda7 /usr ext3 defaults 0 2
/dev/hda1 none swap sw 0 0
/dev/hdc /media/dvd udf,iso9660 user,noauto 0 0

e se l'errore lo da su /usr, il sistema dovrebbe avere difficoltà a partire, perchè in quella partizione ci sono molte cose che servono al SO, giusto? Inoltre ho notato che facendo dmseg il "failed" sparisce: non dovrei avere il verbose del boot con questo comando? Perchè non c'è più l'errore?

Grazie ancora

:ciauz:

Gab-81
22-07-2008, 11:38
UP :bhò:

Gab-81
22-07-2008, 16:54
Risolto!!! Ho semplicemente disinstallato il pacchetto nfs e affini e tutto ok...boot senza errori!!!
Grazie francofait per gli interventi nel forum :)

:ciauz:

Loading