PDA

Visualizza la versione completa : Wireless debian lenny


Alberto
24-08-2008, 15:41
Sto cercando di far andare la scheda Intel PRO/Wireless 2200BG di un portatile asus con Debian Lenny.

Il modulo caricato

# lsmod |grep ipw
ipw2200 130760 0
ieee80211 30632 1 ipw2200
firmware_class 9088 2 pcmcia,ipw2200


ho scaricato e copiato il firmware 3.0 nella dir /urs/lib

ho dato i comandi rmmod ipw2200 e poi modprobe ipw2200

La scheda continua a non andare, cos'altro devo fare?

francofait
24-08-2008, 16:01
come fa a caricarlo in memoria modprobe se lo hai rimosso(rmmod=removemodule) e di conseguenza non c' pi ?

gio14
24-08-2008, 20:30
Originariamente inviato da Alberto
Sto cercando di far andare la scheda Intel PRO/Wireless 2200BG di un portatile asus con Debian Lenny.

Il modulo caricato


ho scaricato e copiato il firmware 3.0 nella dir /urs/lib

ho dato i comandi rmmod ipw2200 e poi modprobe ipw2200

La scheda continua a non andare, cos'altro devo fare?

Domanda stupida, la scheda accesa ?
iwconfig cosa ti dice ? e ifconfig ?

Alberto
25-08-2008, 10:23
Originariamente inviato da gio14
Domanda stupida, la scheda accesa ?
iwconfig cosa ti dice ? e ifconfig ?

La domanda non stupida, infatti la scheda non la vedo accesa :fagiano: ...come faccio ad accenderla?


Originariamente inviato da francofait
come fa a caricarlo in memoria modprobe se lo hai rimosso(rmmod=removemodule) e di conseguenza non c' pi ?

Girando avevo trovato una soluzione su di un forum debian con il titolo Risolto e mi sono fidato...il ragazzo alla fine del 3d era tutto contento perch navigava in wireless... :bh:

quindi che faccio devo recuperare il modulo e ricaricarlo?

gio14
25-08-2008, 11:28
Originariamente inviato da Alberto
La domanda non stupida, infatti la scheda non la vedo accesa :fagiano: ...come faccio ad accenderla?

Dovrebbe avere un tasto d'accensione da qualche parte, ad esempio io ho un HP ed ha un tasto illuminato(quando la scheda accesa) sotto lo schermo, e in un primo momento l'avevo scambiato per una spia, e quando ho installato il firmware e compilato il kernel con il modulo per la mia scheda mi si era spento
comunque pra ha guardare con "lsmod" se il modulo per la scheda caricato(ha vedere dal tuo primo post sembrerebbe di si) poi prova ha dare "iwconfig" per vedere cosa dice

SlAcKj
25-08-2008, 17:06
ti consiglio di installarti wicd o kwlan se utilizzi il router con chiave wpa, se acceso l'hardware, ovvio ed il modulo corretto.

Altrimenti installati ndiswrapper per i driver di windows, metti in blacklist quelli del kernel e vedi che con wicd va tutto a posto, ciao :dh:

Alberto
25-08-2008, 19:45
Originariamente inviato da gio14
Dovrebbe avere un tasto d'accensione da qualche parte, ad esempio io ho un HP ed ha un tasto illuminato(quando la scheda accesa) sotto lo schermo, e in un primo momento l'avevo scambiato per una spia, e quando ho installato il firmware e compilato il kernel con il modulo per la mia scheda mi si era spento
comunque pra ha guardare con "lsmod" se il modulo per la scheda caricato(ha vedere dal tuo primo post sembrerebbe di si) poi prova ha dare "iwconfig" per vedere cosa dice

La spia ce l'ho ed spenta, ma non trovo nessun tasto d'accensione :(

il modulo ancora caricato

# lsmod |grep ipw
ipw2200 130760 0
ieee80211 30632 1 ipw2200
firmware_class 9088 2 pcmcia,ipw2200

iwconfig mi dice
# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

idee?

SlAcKj
25-08-2008, 19:52
L'hw non acceso :
iwconfig:
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:"NETGEAR"
Mode:Managed Frequency:2.437 GHz Access Point: 00:1B:2F:78:0D:20
Bit Rate=54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx Security mode:open
Power Management:off
Link Quality:53/100 Signal level:-62 dBm Noise level:-96 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Alberto
25-08-2008, 20:08
Originariamente inviato da SlAcKj
L'hw non acceso

E fino li l'avevo capito, come fare per accenderlo dato che non c' il pulsante sul mio pc?

gio14
25-08-2008, 20:22
Originariamente inviato da Alberto
E fino li l'avevo capito, come fare per accenderlo dato che non c' il pulsante sul mio pc?

Prova ha spulciare il manuale del PC oppure con google se trovi delle info, da qualche parte deve pure esserci

Loading