PDA

Visualizza la versione completa : linux JAVA


laguna86
25-08-2008, 11:53
Praticamente ho un problema con una parte di codice Java su linux (dico su linux perchè questo stesso codice su win funziona).

Vector <String> dati = new Vector<String>();

Eclipse mi sottolinea in rosso String e mi dice : "Syntax error, parameterized types are only available if source level is 1.5"

Tengo a precisare che la JRE è la stessa, sia su win dove funziona, sia su linux, anche eclipse è lo stesso e cioè 3.4.0

Lo stesso errore mi da sul tipo enum:

public enum mesi{
Gennaio, Febbraio, Marzo, Aprile, Maggio, Giugno, Luglio,
Agosto, Settembre, Ottobre, Novembre, Dicembre
}

Spero in una vostra risposta, grazie.

nifriz
25-08-2008, 12:02
Era meglio chiedessi nel forum java, comunque dovrebbe esserci di Default un opzione che specifica per quale target compilare. Probabilmente usi istruzioni utilizziabili solo dalla jre 1.5 e cerchi di compilare per un target inferiore...

cacao74
25-08-2008, 13:19
verifica che la JVM di riferimento sia la stessa sui vari sistemi operativi.
"java -version" ti aiutera'.

ciao

laguna86
25-08-2008, 18:08
Ok grazie per le info, ho risolto impostando il parametro del Compiler di Eclipse alla 1.6

Ciuz

Loading